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Chargement lent de SAP Ariba Supplier Lifecycle & Performance
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Symptôme

Le chargement de SAP Ariba Supplier Lifecycle and Performance est lent lors de l'ouverture de Supplier Management ou de la création de nouvelles demandes fournisseur.


Environnement

Gestion des fournisseurs


Reproduction du problème

Connectez-vous au domaine et essayez d'ouvrir la gestion des fournisseurs ou essayez de créer une demande fournisseur.


Cause

Cela peut être dû à de nombreux éléments tels que la connectivité Internet, les paramètres de sécurité ou les temps de réponse du serveur SAP Ariba. Vous pouvez diagnostiquer avec précision la cause profonde en exécutant certains dans les diagnostics du navigateur. Suivez les étapes de la section Informations supplémentaires ci-dessous pour collecter les données requises pour l'analyse.


Résolution
Informations supplémentaires
  1. Connectez-vous à votre solution SAP Ariba Spend Management et accédez à l'onglet Accueil, et non à Supplier Management.
  2. Cliquez avec le bouton droit de la souris n'importe où sur la page et choisissez "inspecter" (ou "inspecter l'élément" selon votre navigateur) pour ouvrir la console des outils de développement.
  3. Accédez à l'onglet Réseau dans votre console Outils de développement.
  4. Dans Mozilla Firefox et Google Chrome, cliquez sur le bouton Effacer situé en haut de la console. Dans IE et Edge, cliquez sur le bouton Effacer la session situé en haut de la console. Les icônes de bouton varient d'un navigateur à l'autre, alors placez le curseur sur l'icône pour voir son nom.
  5. Une fois que la console a été supprimée des demandes réseau, cliquez sur l'onglet Gestion des fournisseurs dans Ariba.
  6. Toutes les ressources chargées à partir des serveurs d'Ariba seront affichées et nous fourniront des informations sur chaque demande de chargement.

Étant donné que SAP Ariba Supplier Lifecycle & Performance est conçu à l'aide d'une architecture de micro-services, il y aura beaucoup de demandes dans l'onglet Réseau. Vous devrez analyser ces demandes pour voir ce qui cause la frustration maximale en temps de chargement. Il doit y avoir une colonne dans la console des outils de développement pour le temps nécessaire à chaque requête. Pour analyser chaque demande :

  1. cliquez sur ces demandes pour générer une nouvelle fenêtre dans la console avec plus de détails sur la demande.
  2. dans cette nouvelle fenêtre, cliquez sur l'onglet chronométrage qui décompose les délais. Chaque navigateur aura des détails différents pour le minutage.

Il est recommandé de consulter votre service informatique lors de l'analyse des données. Cependant, chaque navigateur doit fournir un temps d'attente. C'est le temps que prennent les serveurs d'Ariba pour répondre. Les horaires environnants concernent principalement votre environnement local.

Dans la liste des demandes, il est préférable d'analyser les demandes ayant le plus de temps pour terminer en premier. Examinez ensuite la répartition temporelle de chacune de ces demandes afin de voir quelle étape de la demande est à l'origine de la plus grande frustration en termes de calendrier.



S'applique à

Supplier Lifecycle and Performance

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