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Erro de conexão com adaptador AN - Não é possível conectar ao Ariba SNcom.ariba.asc.connector.exception.AribaSNException: não é possível conectar ao Ariba SN- Causado por: java.net.ConnectException: Timeout de conexão: conexão
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Problema

Problema de conexão no adaptador AN padrão, ao chamar os documentos da fila pendente, abaixo está o erro dos logs de depuração do remetente cxml no PI 

Timeout de conexão:

#2.0 #2017 12 06 16:55:16:257#+00#Error#$Id:aribaplatformintegrationcXMLConnectorascadapterreleasecore2.42.1+comaribaascconnectorexceptionutilExceptionMgr.java\#1$#

##ariba.com/com.ariba.asc.sap.netweaver.xiadapter.ra#C0000A11C911002B000A952F00001A24#607095650000000785##$Id:aribaplatformintegrationcXMLConnectorascadapterreleasecore2.42.1+comaribaascconnectorexceptionutilExceptionMgr.java\#1$.handleError##60879527d8aa11e7be440000242f8b62 60879527d8aa11e7be440000242f8b62 Exception#Exception e, ChannelProfile cp) [y_60879527D8AA11E7BE440000242F8B62#

[CC_Invoice02_cXML_Sender] [Nível de erro] 2[Código de erro] ECC103[Descrição do erro] Ariba SN não disponível[Mensagem de erro] Não é possível conectar ao Ariba SNcom.ariba.asc.connector.exception.AribaSNException: impossível conectar ao Ariba SN

                em com.ariba.asc.connector.cxml.util.CXMLSender.sendRequest(CXMLSender.java:252)

                em com.ariba.asc.connector.cxml.util.CXMLSender.sendCXMLRequest(CXMLSender.java:157)

                em com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.sendProfileRequest(ProfileUpdateAction.java:192)

                em com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.updateProfile(ProfileUpdateAction.java:165)

                em com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.updateChannelProfile(ProfileUpdateAction.java:123)

                em com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.execute(ProfileUpdateAction.java:79)

                em com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ScheduleTaskMgr.run(ScheduleTaskMgr.java:151)

                em com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

                em java.security.AccessController.doPrivileged(Native Method)

                em com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:185)

                em com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:302)

Causado por: java.net.ConnectException: tempo limite de conexão: conexão

                em java.net.PlainSocketImpl.socketConnect(Método nativo)

                em java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)

                em java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)

                em java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)

                em java.net.SocksSocketImpl.connect(SocksSocketImpl.java:365)

                em java.net.Socket.connect(Socket.java:529)

                em com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:570)

                em com.sun.net.ssl.internal.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:412)

                em com.sun.net.ssl.internal.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:123)

                em com.ariba.asc.connector.cxml.util.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:95)

                em com.ariba.asc.connector.cxml.util.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:163)

                em org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:704)

                em org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:384)

                em org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:170)

                em org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:396)

                em org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:324)

                em com.ariba.asc.connector.cxml.util.CXMLSender.sendRequest(CXMLSender.java:200)

                ... mais 10

 

  1. Vemos uma solicitação de perfil sendo acionada a partir do adaptador emissor AN a partir dos logs; esta é a etapa de autenticação inicial, veja acima. E há um “tempo limite de conexão” depois disso. 
Causa

Na maioria dos casos, esse tempo de conexão se deve a problemas de rede entre o servidor PI do cliente e o AN.

Solução

O cliente precisa testar primeiro a conexão com o service.ariba.com a partir do nível de servidor PI OS para ver se consegue acessar o servidor.

Abaixo está uma forma de o cliente poder testar a conexão a partir do seu servidor PI (nível do SO)

  1. Comando a ser utilizado: openssl s_client -state -connect service.ariba.com:443
    Nota: você precisa ter o openSSL instalado em seu servidor PI para fazer esse teste, você pode entrar em contato com sua equipe de rede para obter mais detalhes sobre isso.
    Você deve ver o seguinte em caso de sucesso

Em caso de erro, você recebe um erro como abaixo ( amostra). Isso significa que seu servidor SAP PI não consegue acessar o Ariba Network e você precisa verificar mais detalhadamente com sua equipe de rede sobre isso, isso é mais um problema de rede em vez de um problema de adaptador de AN.

 

 

 

  1. Teste Telnet:

    Telnet pode ser usado como um teste alternativo, mas nenhuma saída será mostrada em caso de sucesso.

 

telnet service.ariba.com 443

 

Em caso de êxito (nenhuma mensagem de erro). O cursor estará piscando.

 

Em caso de erro (problema de rede)

 

Assim, verifique a conexão ao AN a partir de seu servidor PI, se não funcionar como explicado acima a partir do nível do seu SO, isso significa que o problema está na rede do cliente e não no adaptador do AN. O cliente precisa verificar mais com sua equipe de rede em caso de problemas de rede.

Informações adicionais

Porta TCP 443 para service.ariba.com que resolve 216.109.104.11.  

O endereço IP para service.ariba.com é 216.109.104.11.

Além disso, veja abaixo os intervalos de IP suportados pela Ariba:

 

URL:

https://support.ariba.com/item/view/82001

 

URL do Ariba Connect:

https://support.ariba.com/item/view/82001 

 

Observação: o cliente confirmou que não conseguiu telnet service.ariba.com quando enfrentou esse problema, o que provou que o problema era com a rede do cliente a partir de seu servidor PI, trabalhou com sua equipe de rede interna para abrir as conexões, após o qual a conexão começou a funcionar. Este é um problema de rede que precisa ser resolvido pelo cliente.


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