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Posta elettronica
Errore di connessione con l'adattatore AN - Impossibile connettersi ad Ariba SNcom.ariba.asc.connector.Exception.AribaSNException: Impossibile connettersi ad Ariba SN- Caused by: java.net.ConnectException: Timeout della connessione: connessione
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Problema

Problema di connessione nell'adattatore AN standard, durante il pull dei documenti dalla coda di attesa; di seguito è riportato l'errore dai registri di debug del mittente cxml in PI 

Timeout di connessione:

#2.0 #2017 12 06 16:55:16:257#+00#Error#$Id:aribaplatformintegrationcXMLConnectorascadapterreleasecore2.42.1+comaribaascconnectorecceziontionutilExceptionMgr.java\#1$#

##ariba.com/com.ariba.asc.sap.netweaver.xiadapter.ra#C0000A11C911002B000A952F00001A24#607095650000000785#$Id:aribaplatformintegrationcXMLConnectorascadapterreleasecore2.42.1+comaribaascconnectorExceptionutilExceptionMgr.java\#1$.handleError(e, ChannelProfile#60879527d8aa11e7be440000242f8b62 60879527d8aa11e7be440000242f8b62 cp#0)#deploy_service#69$.handleError(e, ChannelProfile#cp)#0#deployamento60879527D8AA11E7BE440000242F8B62

[CC_Invoice02_cXML_Sender] [Livello errore] 2[Codice errore] ECC103[Descr. errore] Ariba SN non disponibile[Messaggio di errore] Impossibile connettersi ad Ariba SNcom.ariba.asc.connector.Exception.AribaSNException: impossibile connettersi ad Ariba SN

                all'indirizzo com.ariba.asc.connector.cxml.util.CXMLSender.sendRequest(CXMLSender.java:252)

                all'indirizzo com.ariba.asc.connector.cxml.util.CXMLSender.sendCXMLRequest(CXMLSender.java:157)

                all'indirizzo com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.sendProfileRequest(ProfileUpdateAction.java:192)

                all'indirizzo com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.updateProfile(ProfileUpdateAction.java:165)

                all'indirizzo com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.updateChannelProfile(ProfileUpdateAction.java:123)

                all'indirizzo com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.perform(ProfileUpdateAction.java:79)

                all'indirizzo com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ScheduleTaskMgr.run(ScheduleTaskMgr.java:151)

                all'indirizzo com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

                all'indirizzo java.security.AccessController.doPrivileged(Native Method)

                all'indirizzo com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:185)

                all'indirizzo com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:302)

Causato da: java.net.ConnectException: Timeout della connessione: connessione

                at java.net.PlainSocketImpl.socketConnect(Native Method)

                at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)

                su java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)

                at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)

                at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:365)

                at java.net.Socket.connect(Socket.java:529)

                a com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:570)

                a com.sun.net.ssl.internal.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:412)

                a com.sun.net.ssl.internal.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:123)

                all'indirizzo com.ariba.asc.connector.cxml.util.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:95)

                all'indirizzo com.ariba.asc.connector.cxml.util.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:163)

                all'indirizzo org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:704)

                all'indirizzo org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:384)

                all'indirizzo org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:170)

                all'indirizzo org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:396)

                all'indirizzo org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:324)

                all'indirizzo com.ariba.asc.connector.cxml.util.CXMLSender.sendRequest(CXMLSender.java:200)

                ... 10 in più

 

  1. Viene avviata una richiesta di profilo dall'adattatore mittente AN dai registri. Questa è la fase di autenticazione iniziale, vedere sopra. E dopo c’è un “Connection time out”. 
Causa

Questo timeout della connessione nella maggior parte dei casi è dovuto a problemi di rete tra il server PI del cliente e AN.

Soluzione

Il cliente deve prima testare la connessione a service.ariba.com dal proprio livello di server PI OS per verificare se è in grado di accedere al server.

Di seguito è riportato un modo in cui il cliente può testare la connessione dal proprio server PI (livello OS)

  1. Comando da utilizzare: openssl s_client -state -connect service.ariba.com:443
    Nota: è necessario che openSSL sia installato nel server PI per eseguire questo test, è possibile contattare il team di rete per ulteriori dettagli su questo.
    Dovresti vedere quanto segue in caso di successo

In caso di errore, si riceve un errore come quello sotto (campione). Ciò significa che il server SAP PI non è in grado di raggiungere Ariba Network ed è necessario verificare ulteriormente con il team di rete in merito a questo; si tratta più di un problema di rete che di adattatore AN.

 

 

 

  1. Test Telnet:

    Telnet può essere utilizzato come test alternativo, ma in caso di successo non verrà mostrato alcun output.

 

telnet service.ariba.com 443

 

In caso di corretta esecuzione (nessun messaggio di errore). Il cursore lampeggia.

 

In caso di errore (problema di rete)

 

Pertanto, si prega di controllare la connessione ad AN dal server PI, se non funziona come spiegato sopra dal livello di sistema operativo, significa che il problema è con la rete del cliente e non con l'adattatore AN. Il cliente deve effettuare ulteriori controlli con il team di rete in caso di problemi di rete.

Informazioni supplementari

Porta TCP da 443 a service.ariba.com che si risolve in 216.109.104.11.  

L'indirizzo IP di service.ariba.com è 216.109.104.11.

Oltre a ciò, di seguito sono disponibili gli intervalli IP supportati da Ariba:

 

URL:

https://support.ariba.com/item/view/82001

 

URL Ariba Connect:

https://support.ariba.com/item/view/82001 

 

Nota: il cliente ha confermato di non essere in grado di telnet service.ariba.com quando ha affrontato questo problema che ha dimostrato che il problema riguardava la rete del cliente dal suo server PI, ha lavorato con il team di rete interno per aprire le connessioni, dopodiché la connessione ha iniziato a funzionare. Si tratta di un problema di rete che deve essere risolto dal cliente.


Si applica a

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