Support-Hinweis KB0397721
E-Mail
Verbindungsfehler mit AN-Adapter - Verbindung zu Ariba SNcom.ariba.asc.connector.exception.AribaSNException: Verbindung zu Ariba SNC nicht möglich - verursacht durch: java.net.ConnectException: Zeitüberschreitung bei Verbindung: Verbinden
Dieser Wissensdatenbankartikel wurde maschinell übersetzt. SAP übernimmt keine Gewährleistung für die Richtigkeit oder Vollständigkeit der Maschinenübersetzung. Sie können den Originalinhalt anzeigen, indem Sie über die Sprachauswahl zu "Englisch" wechseln.
Problem

Verbindungsproblem im Standard-AN-Adapter: Beim Abrufen der Dokumente aus der Warteschlange für anstehende Dokumente tritt der folgende Fehler aus den cXML-Sender-Debug-Protokollen in PI auf: 

Verbindungs-Timeout:

#2.0 #2017 12 06 16:55:16:257#+00#Fehler#$Id:aribaplatformintegrationcXMLConnectorascadapterreleasecore2.42.1+comaribaascconnectorexceptionutilExceptionMgr.java\#1$#

##ariba.com/com.ariba.asc.sap.netweaver.xiadapter.ra#C0000A11C911002B000A952F00001A24#607095650000000785##$Id:aribaplatformintegrationcXMLConnectorascadapterreleasecore2.42.1+comaribaascconnectorexceptionutilExceptionMgr.java\#1$.handleError(Exception e, ChannelProfile Application cp) 60879527d8aa11e7be440000242f8b62#y_#60879527d8aa11e7be440000242f8b62 0#60879527D8AA11E7BE440000242F8B62 0#

[CC_Invoice02_cXML_Sender] [Error Level] 2[Error Code] ECC103[Error Desc] Ariba SN Not Available[Error Message] Cannot connect to Ariba SNcom.ariba.asc.connector.exception.AribaSNException: Cannot connect to Ariba SN

                at com.ariba.asc.connector.cxml.util.CXMLSender.sendRequest(CXMLSender.java:252)

                at com.ariba.asc.connector.cxml.util.CXMLSender.sendCXMLRequest(CXMLSender.java:157)

                at com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.sendProfileRequest(ProfileUpdateAction.java:192)

                at com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.updateProfile(ProfileUpdateAction.java:165)

                at com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.updateChannelProfile(ProfileUpdateAction.java:123)

                at com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.perform(ProfileUpdateAction.java:79)

                at com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ScheduleTaskMgr.run(ScheduleTaskMgr.java:151)

                at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

                at java.security.AccessController.doPrivileged(Native Method)

                at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:185)

                at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:302)

Caused by: java.net.ConnectException: Connection timed out: connect

                bei java.net.PlainSocketImpl.socketConnect(Native Method)

                at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)

                at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)

                at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)

                at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:365)

                at java.net.Socket.connect(Socket.java:529)

                at com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:570)

                at com.sun.net.ssl.internal.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:412)

                at com.sun.net.ssl.internal.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:123)

                at com.ariba.asc.connector.cxml.util.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:95)

                at com.ariba.asc.connector.cxml.util.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:163)

                at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:704)

                at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:384)

                at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:170)

                at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:396)

                at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:324)

                at com.ariba.asc.connector.cxml.util.CXMLSender.sendRequest(CXMLSender.java:200)

                ... 10 weitere

 

  1. Aus den Protokollen wird eine Profilanforderung vom AN-Sender-Adapter ausgelöst. Dies ist der initiale Authentifizierungsschritt, siehe oben. Und danach kommt es zu einem „Verbindungs-Timeout“. 
Ursache

Diese Zeitüberschreitung der Verbindung ist in den meisten Fällen auf Netzwerkprobleme zwischen dem PI-Server des Kunden und AN zurückzuführen.

Lösung

Der Kunde muss zuerst die Verbindung zu service.ariba.com von seiner PI-Betriebssystemserver-Ebene testen, um festzustellen, ob er auf den Server zugreifen kann.

Im Folgenden finden Sie eine Möglichkeit, wie der Kunde die Verbindung von Ihrem PI-Server aus testen kann (Betriebssystemebene).

  1. Zu verwendender Befehl : openssl s_client -state -connect service.ariba.com:443
    Hinweis: Sie müssen openSSL auf Ihrem PI-Server installiert haben, um diesen Test durchzuführen. Weitere Informationen erhalten Sie von Ihrem Netzwerkteam.
    Im Erfolgsfall sollten Sie Folgendes sehen:

Im Fehlerfall erhalten Sie einen Fehler wie den folgenden (Beispiel). Das bedeutet, dass Ihr SAP-PI-Server Ariba Network nicht erreichen kann und Sie sich diesbezüglich weiter mit Ihrem Netzwerkteam in Verbindung setzen müssen. Dies ist eher ein Netzwerkproblem als ein AN-Adapterproblem.

 

 

 

  1. Telnet-Test:

    Telnet kann als alternativer Test verwendet werden, aber im Erfolgsfall wird keine Ausgabe angezeigt.

 

telnet service.ariba.com 443

 

Im Erfolgsfall (keine Fehlermeldung). Der Cursor blinkt.

 

Im Fehlerfall (Netzwerkproblem)

 

Prüfen Sie daher die Verbindung zu AN von Ihrem PI-Server. Wenn dies auf Betriebssystemebene nicht wie oben beschrieben funktioniert, bedeutet dies, dass das Problem beim Netzwerk des Kunden und nicht beim AN-Adapter auftritt. Der Kunde muss sich bei Netzwerkproblemen weiter mit Ihrem Netzwerkteam in Verbindung setzen.

Zusätzliche Informationen

TCP-Port 443 bis service.ariba.com, der in 216.109.104.11 aufgelöst wird.  

Die IP-Adresse für service.ariba.com lautet 216.109.104.11.

Darüber hinaus finden Sie unten die von Ariba unterstützten IP-Bereiche:

 

URL:

https://support.ariba.com/item/view/82001

 

Ariba-Connect-URL:

https://support.ariba.com/item/view/82001 

 

Hinweis: Der Auftraggeber hat bestätigt, dass er nicht in der Lage war, service.ariba.com zu telnetten, wenn es sich um ein Problem mit dem Auftraggebernetzwerk von seinem PI-Server handelt. Er arbeitete mit seinem internen Netzwerkteam zusammen, um die Verbindungen zu öffnen, nach denen die Verbindung begann zu funktionieren. Dies ist ein Netzwerkproblem, das vom Kunden behoben werden muss.


Gilt für

SAP Business Network for Procurement und Supply Chain

Nutzungsbedingungen  |  Copyright  |  Sicherheitsrichtlinie  |  Vertraulichkeit