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Internet 通信框架 (ICM) CI9 直接连接中出现 SOAMANAGER 处理错误
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症状

作为 CI9(云集成 9)直接连接集成的一部分,我们在 SOAMANAGER 中配置了以下 2 个 Web 服务:

  1. /ARBA/CO_MIOUT_SYNC_ARIBA_DOWN
  2. /ARBA/CO_MIOUT_SYNC_ARIBA_UPLO

SOAMANAGER 屏幕上的这两个 Web 服务上进行“Ping Web 服务”测试时,会收到以下错误消息:

“SRT 框架异常:服务 Ping 错误:调用 SOAP 运行时函数时出错:SRT:Internet 通信框架中出现处理错误:(“连接到 s1.ariba.com:443 失败:NIECONN_REFUSED(-10)”)。


原因

可能有两个原因:

  1. ICM HTTPS 端口号可能不正确
  2. s1.ariba.comSTRUST 中可能缺少 SSL 证书


解决方案

ICM HTTPS 端口的端口应为 443。

如果 HTTPS 端口不是 443,则在对 Web 服务执行 ping 时我们收到以下错误:

“SOAP 运行时框架异常:服务 Ping 错误:调用 SOAP 运行时功能时出错:SOAP 运行时:Internet 通信框架中出现处理错误:(“HTTPIO_PLG_CANCELED”)”

附加信息

如果使用 SOAMANAGER 直接连接方法,则需要确保在 ECCERP Central Component系统的 STRUST(信任管理器)中导入所需的 Ariba 证书。有关详细步骤,请参阅如何安装 HTTPS 连接的 SSL 客户端证书

有关 Ariba 证书的列表和下载链接,请参阅 SAP Ariba 公共 DigiCert Web 服务器证书。

ECC 系统中安装公共服务器证书就足够了。但是,始终建议同时安装中间证书和公共服务器证书。

安装证书后,您应该会在 STRUST 中看到一个条目,作为 SSL 系统集团 SSL 集团,其中包含导入证书的内容。

所需证书准备就绪且 SOAMANAGER 设置正确后(请参阅如何配置 SOAMANAGER),对 Web 服务执行 ping 时应看到如下消息:

“Web 服务 ping 失败 (RC=403)。服务 Ping 错误:已禁止”



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