지원 참고 사항 KB0396460
전자우편
인터넷 통신 프레임워크(ICM) CI9 직접 연결에서 SOAMANAGER 처리 오류가 발생했습니다.
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증상

CI9(클라우드 통합 9) 직접 연결 통합의 일부로, SOAMANAGER 에서 아래의 웹 서비스 2개를 구성했습니다.

  1. /ARBA/CO_MIOUT_SYNC_ARIBA_DOWN
  2. /ARBA/CO_MIOUT_SYNC_ARIBA_UPLO

SOAMANAGER 화면의 두 웹 서비스 모두에서 "Ping 웹 서비스" 테스트를 수행하면 다음과 같은 오류 메시지가 표시됩니다.

“SRT 프레임워크 예외: 서비스 Ping 오류: SOAP 런타임 기능을 호출하는 동안 오류 발생: SRT: 인터넷 통신 프레임워크에서 처리 오류 발생: ("s1.ariba.com:443에 연결 실패: NIECONN_REFUSED(-10)")"


원인

다음과 같은 두 가지 원인이 있습니다.

  1. ICM HTTPS 포트 번호가 잘못되었을 수 있습니다.
  2. s1.ariba.comSTRUST에 SSL 인증서가 누락되었을 수 있습니다.


해결

ICM HTTPS 포트 에는 포트 443으로 지정되어 있어야 합니다.

HTTPS 포트가 443이 아니면 웹 서비스를 ping할 때 아래 오류가 발생합니다.

"SRT 프레임워크 예외: 서비스 Ping 오류: SOAP 런타임 기능을 호출하는 동안 오류 발생: SRT: 인터넷 통신 프레임워크에서 처리 오류 발생: ("HTTPIO_PLG_CANCELED")"

추가 정보

SOAMANAGER 직접 연결 방법을 사용하는 경우, ECC(ERP Central Component) 시스템의 STRUST(트러스트 관리자)에서 필요한 Ariba 인증서를 가져와야 합니다. 자세한 단계는 HTTPS 연결을 위한 SSL 클라이언트 인증서를 설치하는 방법 을 참조하십시오.

Ariba 인증서의 목록과 다운로드 링크는 SAP Ariba Public DigiCert Web Server Certificates 를 참조하십시오.

ECC 시스템에 공용 서버 인증서를 설치하기만 하면 됩니다. 그러나 항상 중간 인증서와 공용 서버 인증서를 설치하는 것이 좋습니다.

인증서를 설치한 후 임포트된 인증서의 컨텐트와 함께 STRUST에 SSL 시스템 클라이언트 SSL 클라이언트 엔트리가 표시되어야 합니다.

필요한 인증서가 준비되어 있고 SOAMANAGER 설정이 올바르면(SOAMANAGER 구성 방법 참조) 웹 서비스를 ping할 때 다음과 같은 메시지가 표시되어야 합니다.

"웹 서비스 ping에 실패했습니다(RC=403). 서비스 Ping 오류: 금지됨"



적용 대상

SAP Business Network for Procurement & Supply Chain

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