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SOAMANAGER Erreur de traitement dans Internet Communication Framework (ICM) CI9 Connectivité directe
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Symptôme

Dans le cadre de l'intégration de la connectivité directe CI9 (Cloud Integration 9), nous avons configuré les 2 services Web ci-dessous dans SOAMANAGER :

  1. /ARBA/CO_MIOUT_SYNC_ARIBA_DOWN
  2. /ARBA/CO_MIOUT_SYNC_ARIBA_UPLO

Lorsque nous effectuons le test "Ping service Web" sur ces deux services Web sur l'écran SOAMANAGER, le message d'erreur suivant s'affiche :

"Exception SRT Framework : ERREUR de ping de service : erreur lors de l'appel des fonctions SOAP Runtime : SRT : erreur de traitement dans Internet Communication Framework : ("Échec de connexion à s1.ariba.com:443 : NIECONN_REFUSED(-10)")".


Cause

Il peut y avoir deux causes :

  1. Le numéro de port HTTPS ICM est peut-être incorrect.
  2. Les certificats SSL peuvent être manquants dans STRUST pour s1.ariba.com


Résolution

Le port HTTPS ICM doit avoir le port 443.

Si le port HTTPS n'est pas 443, l'erreur suivante s'affiche lors du ping du service Web :

"Exception SRT Framework : ERREUR de ping de service : erreur lors de l'appel des fonctions d'exécution SOAP : SRT : erreur de traitement dans Internet Communication Framework : ("HTTPIO_PLG_CANCELED")"

Informations supplémentaires

Si vous utilisez la méthode de connectivité directe SOAMANAGER, vous devez vous assurer que les certificats Ariba requis sont importés dans STRUST (Trust Manager) de votre système ECC (ERP Central Component). Reportez-vous à Comment installer le certificat client SSL pour la connexion HTTPS pour connaître les étapes détaillées.

Reportez-vous à Certificats de serveur Web DigiCert publics SAP Ariba pour obtenir une liste et télécharger des liens vers les certificats Ariba.

Il suffit d'avoir le certificat de serveur public installé dans votre système ECC. Cependant, il est toujours recommandé d'installer le certificat intermédiaire ainsi que le certificat du serveur public.

Après avoir installé les certificats, vous devez voir une entrée dans STRUST comme Client système SSL Client SSL avec le contenu du certificat importé.

Une fois que les certificats requis sont en place et que les options SOAMANAGER sont correctes (voir Comment configurer SOAMANAGER), vous devez voir un message comme ci-dessous lorsque vous effectuez un ping sur le service Web :

"Échec du ping du service Web (RC=403). ERREUR de ping de service : interdit"



S'applique à

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