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Posta elettronica
Un'area di lavoro contratti con un tipo di condizione vuoto o nascosto non è scaduta alla data di scadenza
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Sintomo

Un'area di lavoro contratti con una data di scadenza nel passato è ancora pubblicata. Nell'area Attributi di durata del contratto dell'area di lavoro, il campo Tipo di durata è vuoto o nascosto.


Riproduzione del problema

Prima di novembre 2020, questo comportamento potrebbe essere visualizzato in un'area di lavoro contratti se non è stato selezionato un valore per il campo Tipo di condizione prima della pubblicazione dell'area di lavoro. La possibilità di creare un'area di lavoro contratti con un campo Tipo di condizione vuoto era principalmente il risultato di una delle seguenti personalizzazioni:


Causa

In precedenza, se il sito era stato personalizzato in modo da rendere il campo Tipo di condizione dell'area di lavoro contratti facoltativo o nascosto, SAP Ariba consentiva di creare un'area di lavoro contratti con un campo Tipo di condizione vuoto.

Tuttavia, è stata introdotta una correzione del codice (SC-12453) con la versione trimestrale di novembre 2020 (2011) per affrontare questo comportamento. Ora, se si personalizza il sito per rendere il campo Tipo di condizione dell'area di lavoro contratti facoltativo o nascosto, SAP Ariba imposta automaticamente il valore del campo Tipo di condizione su Fisso. Senza un valore nel campo Tipo di condizione, un'area di lavoro contratti non scade mai, quindi questa modifica garantisce che tutte le aree di lavoro abbiano un valore per il Tipo di condizione.


Soluzione

Per forzare la scadenza delle aree di lavoro contratti interessate, è necessario fornire un valore per il campo Tipo di durata. Per completare questa azione, sarà necessario individuare le aree di lavoro interessate, utilizzare lo strumento di modifica di massa per il progetto per modificare il tipo di condizione, quindi attendere l'esecuzione dell'attività di aggiornamento dello stato del contratto (questa attività viene eseguita una volta al giorno).

Innanzitutto, creare un elenco degli spazi di lavoro interessati:

Successivamente, aggiungere le aree di lavoro interessate a un batch nello strumento di modifica di massa del progetto:

  1. Nel quadrante, selezionare Gestisci > Amministrazione
  2. Nella pagina Amministratore, espandere l'intestazione Responsabile gestione progetti, quindi selezionare Modifica di massa per progetti
  3. Nella scheda Cerca della pagina Seleziona progetti, utilizzare l'area Filtro di ricerca per cercare le aree di lavoro contratti interessate:
    1. Nella casella di ricerca del testo libero dell'area Filtro di ricerca, immettere l'ID contratto per un'area di lavoro interessata
    2. Seleziona ricerca
    3. Nella tabella Risultato della ricerca, selezionare la casella di spunta per il contratto interessato
    4. Seleziona Aggiungi
    5. Ripetere queste fasi in base alle esigenze
  4. Confermare le selezioni nel tab Progetti da aggiornare, quindi selezionare Successivo
    Se si desidera utilizzare diversi tipi di condizione per diverse aree di lavoro contratti (ad esempio Fissato per alcune e Con rinnovo tacito per altre), sarà necessario elaborare le aree di lavoro contratti in batch separati

Successivamente, selezionare il campo per aggiornare e mettere in coda il batch di aggiornamento:

  1. Nella pagina Seleziona campi, selezionare Seleziona campi da aggiornare
  2. Nella tabella dei risultati della pagina Seleziona progetto per aggiornare la tabella dei risultati, selezionare la casella di controllo per Tipo di condizione
  3. Selezionare OK
  4. Nella colonna Nuovi valori della riga Tipo di condizione, selezionare il nuovo tipo di condizione da applicare alle aree di lavoro
    Nella maggior parte dei casi, selezionare Fisso
  5. Seleziona successivo

Infine, rivedere le modifiche in coda e inviare l'aggiornamento:

  1. Nella pagina Seleziona campi del gruppo di progetto, selezionare Avanti.
  2. Nella pagina Rivedi modifiche, confermare di aver selezionato i progetti e i campi corretti da aggiornare
  3. Seleziona Aggiorna

Dopo aver inviato il batch di modifica di massa, è possibile controllare lo stato del batch espandendo l'intestazione Gestione progetti della pagina Amministratore, quindi selezionando Stato modifica di massa.

Dopo che lo strumento di modifica di massa completa gli aggiornamenti, le aree di lavoro contratti passeranno allo stato corretto dopo la successiva esecuzione dell'attività Aggiorna stato contratti. Questo task viene eseguito una volta ogni 24 ore, con una pianificazione basata sul fuso orario del Pacifico degli Stati Uniti.


Vedi anche

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Si applica a

Contratti strategici

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