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Un espace de travail Contrat avec un type d'échéance vide ou masqué n'a pas expiré à la date d'expiration.
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Symptôme

Un espace de travail Contrat dont la date d'expiration est située dans le passé est toujours publié. Dans la zone Attributs des conditions du contrat de l'espace de travail, le champ Type d'échéance est vide ou masqué.


Reproduction du problème

Avant novembre 2020, vous pouviez voir ce comportement dans un espace de travail Contrat si vous ne sélectionniez pas de valeur pour le champ Type d'échéance avant de publier l'espace de travail. La possibilité de créer un espace de travail Contrat avec un champ Type d'échéance vide était le plus souvent le résultat de l'une des personnalisations suivantes :


Cause

Auparavant, si vous personnalisiez votre site pour rendre le champ Type d'échéance de l'espace de travail Contrat facultatif ou masqué, SAP Ariba vous permettait de créer un espace de travail Contrat avec un champ Type d'échéance vide.

Cependant, nous avons introduit une correction de code (SC-12453) avec la version trimestrielle de novembre 2020 (2011) pour traiter ce comportement. Désormais, si vous personnalisez votre site pour que le champ Type d'échéance de l'espace de travail Contrat soit facultatif ou masqué, SAP Ariba définit automatiquement la valeur du champ Type d'échéance sur Fixe. Sans valeur dans le champ Type d'échéance, un espace de travail Contrat n'expire jamais. Cette modification garantit donc que tous les espaces de travail ont une valeur pour le Type d'échéance.


Résolution

Pour forcer l'expiration des espaces de travail Contrat concernés, vous devez fournir une valeur pour le champ Type d'échéance. Pour effectuer cette action, vous devrez localiser les espaces de travail concernés, utiliser l'outil de modification en masse du projet pour modifier le type de condition, puis attendre l'exécution de la tâche de mise à jour du statut du contrat (cette tâche s'exécute une fois par jour).

Commencez par créer une liste des espaces de travail affectés :

Ensuite, ajoutez les espaces de travail concernés à un lot dans l'outil de modification en masse du projet :

  1. Sur votre tableau de bord, sélectionnez Gérer > Administration.
  2. Sur la page Administrateur, développez l'en-tête Gestionnaire de projets, puis sélectionnez Modifier des projets en masse.
  3. Dans l'onglet Rechercher de la page Sélectionner des projets, utilisez la zone Filtre de recherche pour rechercher les espaces de travail Contrat concernés :
    1. Dans la zone de recherche en texte libre de la zone Filtre de recherche, saisissez l'ID de contrat d'un espace de travail affecté.
    2. Sélectionner la recherche
    3. Dans la table Résultat de la recherche, cochez la case correspondant au contrat concerné.
    4. Sélectionnez Ajouter.
    5. Répétez ces étapes si nécessaire.
  4. Confirmez vos sélections dans l'onglet Projets à mettre à jour, puis sélectionnez Suivant.
    Si vous souhaitez utiliser différents types de conditions pour différents espaces de travail Contrat (par exemple, Fixe pour certains et Renouvellement automatique pour d'autres), vous devrez traiter les espaces de travail Contrat dans des lots distincts.

Ensuite, sélectionnez la zone pour mettre à jour et mettre en file d'attente le lot de mise à jour :

  1. Sur la page Sélectionner des champs, sélectionnez Sélectionner les champs à mettre à jour.
  2. Dans le tableau Sélectionner les champs de projet pour mettre à jour les résultats de la page, cochez la case Type d'échéance.
  3. Sélectionnez OK.
  4. Dans la colonne Nouvelles valeurs de la ligne Type de condition, sélectionnez le nouveau type de condition que vous souhaitez appliquer aux espaces de travail.
    Dans la plupart des cas, vous devrez sélectionner Fixe.
  5. Sélectionnez Suivant.

Enfin, vérifiez vos modifications en file d'attente et soumettez la mise à jour :

  1. Sur la page Sélectionner les champs du groupe de projet, sélectionnez Suivant.
  2. Sur la page Vérifier les modifications, confirmez que vous avez sélectionné les bons projets et champs à mettre à jour.
  3. Sélectionnez Mettre à jour.

Après avoir soumis le lot de modification en masse, vous pouvez vérifier le statut du lot en développant l'en-tête Gestionnaire de projets de la page Administrateur, puis en sélectionnant Modifier le statut en masse.

Une fois que l'outil de modification en masse a terminé les mises à jour, les espaces de travail Contrat passent au bon statut après la prochaine exécution de la tâche Mettre à jour le statut des contrats. Cette tâche s'exécute une fois toutes les 24 heures, avec une planification basée sur le fuseau horaire du Pacifique des États-Unis.


Voir également

SAP Help Portal :



S'applique à

Contrats stratégiques

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