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Un área de trabajo de contratos con un tipo de condición en blanco u oculto no expiraba en la fecha de expiración
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Síntoma

Aún se publica un área de trabajo de contrato con una fecha de expiración en el pasado. En el área Atributos de término del contrato del área de trabajo, el campo Tipo de término está vacío u oculto.


Problema de Redireccionamiento

Antes de noviembre de 2020, es posible que vea este comportamiento en un área de trabajo de contratos si no ha seleccionado un valor para el campo Tipo de condición antes de publicar el área de trabajo. La capacidad de crear un área de trabajo de contrato con un campo Tipo de condición en blanco suele ser el resultado de una de las siguientes personalizaciones:


Causa

Anteriormente, si personalizaba su sitio para que el campo Tipo de condición del área de trabajo de contrato fuera opcional u oculto, SAP Ariba le permitía crear un área de trabajo de contratos con un campo Tipo de condición en blanco.

Sin embargo, hemos introducido una corrección de código (SC-12453) con la versión trimestral de noviembre de 2020 (2011) para abordar este comportamiento. Ahora, si personaliza su sitio para que el campo Tipo de condición del área de trabajo de contrato sea opcional u oculto, SAP Ariba establece automáticamente el valor del campo Tipo de condición en Fijo. Sin un valor en el campo Tipo de condición, un área de trabajo de contrato nunca expira, por lo que este cambio garantiza que todas las áreas de trabajo tengan un valor para el Tipo de condición.


Resolución

Para forzar el vencimiento de las áreas de trabajo de contrato afectadas, debe proporcionar un valor para el campo Tipo de condición. Para completar esta acción, deberá localizar las áreas de trabajo afectadas, utilizar la herramienta de edición en bloque del proyecto para cambiar el tipo de condición y, a continuación, esperar a que se ejecute la tarea de actualización del estado del contrato (esta tarea se ejecuta una vez al día).

En primer lugar, cree una lista de las áreas de trabajo afectadas:

A continuación, agregue las áreas de trabajo afectadas a un lote en la herramienta de edición en bloque del proyecto:

  1. En su panel de instrucciones, seleccione Gestionar > Administración
  2. En la página Administrador, expanda el encabezado Administrador de proyecto y, a continuación, seleccione Edición en bloque de proyectos
  3. En la pestaña Buscar de la página Seleccionar proyectos, utilice el área Filtro de búsqueda para buscar las áreas de trabajo de contrato afectadas:
    1. En el cuadro de búsqueda de texto libre del área Filtro de búsqueda, introduzca el ID de contrato para un área de trabajo afectada
    2. Seleccionar búsqueda
    3. En la tabla Resultado de búsqueda, marque la casilla de selección para el contrato afectado
    4. Seleccione Añadir
    5. Repita estos pasos según sea necesario
  4. Confirme sus selecciones en la pestaña Proyectos para actualizar y, a continuación, seleccione Siguiente
    Si desea utilizar diferentes tipos de condición para diferentes áreas de trabajo de contrato (por ejemplo, Fijo para algunos y Renovación automática para otros), tendrá que procesar las áreas de trabajo de contrato en lotes separados

A continuación, seleccione el campo para actualizar y ponga en cola el lote de actualización:

  1. En la página Seleccionar campos, seleccione Seleccionar campos para actualizar
  2. En la tabla Seleccionar proyecto para actualizar los resultados de la página, marque la casilla de selección para Tipo de condición
  3. Seleccione OK.
  4. En la columna Nuevos valores de la fila Tipo de condición, seleccione el nuevo tipo de condición que desea aplicar a las áreas de trabajo
    En la mayoría de los casos, querrá seleccionar Fijo
  5. Seleccione Siguiente.

Por último, revise los cambios en cola y envíe la actualización:

  1. En la página Seleccionar campos de grupo de proyecto, seleccione Siguiente
  2. En la página Revisar ediciones, confirme que ha seleccionado los proyectos y campos correctos para actualizar
  3. Seleccione Actualizar

Después de enviar el lote de edición en bloque, puede comprobar el estado del lote expandiendo la cabecera Administrador de proyecto de la página Administrador y, a continuación, seleccionando Estado de edición en bloque.

Después de que la herramienta de edición en bloque complete las actualizaciones, las áreas de trabajo de contrato pasarán al estado correcto después de la siguiente ejecución de la tarea Actualizar estado de contratos. Esta tarea se ejecuta una vez cada 24 horas, con una programación basada en la zona horaria del Pacífico de Estados Unidos.


Ver también

SAP Help Portal:



Se aplica a

Contratos estratégicos

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