Support Note KB0395577
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A contract workspace with a blank or hidden Term Type didn't expire on the expiration date
Symptom

A contract workspace with an expiration date in the past is still published. In the workspace's Contract Term Attributes area, the Term Type field is either blank or hidden.


Reproducing the Issue

Prior to November 2020, you might see this behavior in a contract workspace if you didn't select a value for the Term Type field before publishing the workspace. The ability to create a contract workspace with a blank Term Type field was most commonly the result of one of the following customizations:


Cause

Previously, if you customized your site to make the contract workspace Term Type field optional or hidden, SAP Ariba allowed you to create a contract workspace with a blank Term Type field.

However, we introduced a code correction (SC-12453) with the November 2020 (2011) quarterly release to address this behavior. Now, if you customize your site to make the contract workspace Term Type field optional or hidden, SAP Ariba automatically sets the Term Type field's value to Fixed. Without a value in the Term Type field, a contract workspace never expires, so this change ensures that all workspaces have a value for the Term Type.


Resolution

To force the affected contract workspaces to expire, you must provide a value for the Term Type field. To complete this action, you'll need to locate the affected workspaces, use the project mass edit tool to change the term type, then wait for the contract status update task to run (this task runs once a day).

First, create a list of the affected workspaces:

Next, add the affected workspaces to a batch in the project mass edit tool:

  1. On your dashboard, select Manage > Administration
  2. On the Administrator page, expand the Project Manager heading, then select Mass Edit Projects
  3. On the Select Projects page's Search tab, use the Search Filter area to search for the affected contract workspaces:
    1. In the Search Filter area's free text search box, enter the contract ID for an affected workspace
    2. Select Search
    3. In the Search Result table, select the checkbox for the affected contract
    4. Select Add
    5. Repeat these steps as needed
  4. Confirm your selections on the Projects to Update tab, then select Next
    If you'd like to use different term types for different contract workspaces (for instance, Fixed for some and Auto Renew for others), you'll need to process the contract workspaces in separate batches

Next, select the field to update and queue the update batch:

  1. On the Select Fields page, select Select Fields to Update
  2. In the Select Project fields to update page's results table, select the checkbox for Term Type
  3. Select OK
  4. In the Term Type row's New Values column, select the new term type you'd like to apply to the workspaces
    In most cases, you'll want to select Fixed
  5. Select Next

Finally, review your queued changes and submit the update:

  1. On the Select Project Group Fields page, select Next
  2. On the Review Edits page, confirm that you selected the correct projects and fields to update
  3. Select Update

After you submit the mass edit batch, you can check the batch's status by expanding the Administrator page's Project Manager heading, then selecting Mass Edit Status.

After the mass edit tool completes the updates, the contract workspaces will move to the correct status after the next run of the Update Contracts Status task. This task runs once every 24 hours, with a schedule based on the United States' Pacific Time Zone.


See Also

SAP Help Portal:



Applies To

Strategic Contracts

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