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Guia de solução de problemas do ActiveX Control para Windows 8.1 e Windows 10 para problemas relacionados à DFS
Este artigo da base de conhecimentos foi traduzido automaticamente para sua conveniência. A SAP não fornece qualquer garantia em relação à exatidão ou completude da tradução automática. Você pode encontrar o conteúdo original alternando para inglês, usando o seletor de idioma.
Problema

O controle ActiveX usado para a sincronização de arquivo de desktop (DFS) e para exportar relatórios para uma planilha do Excel precisa ser instalado manualmente ou requer a solução de problemas na máquina de um usuário devido ao mau funcionamento.

Resolução

Mesmo um usuário com direitos administrativos na máquina não pode procurar o conteúdo da pasta "C:\Windows\Arquivos de programa baixados", portanto, precisamos remover arquivos e copiar arquivos para ela usando o prompt de linha de comando. Isso não adultera as permissões e propriedade desta pasta. Para continuar com uma remediação que consiste em depuração de cliente e reinstalação manual, siga estas etapas:

  1. Faça o download do arquivo clientautomation.zip anexado a esta página e descompacte seu conteúdo na unidade C:.
  2. Abra Iniciar e digite "cmd", clique com o botão direito do mouse no ícone chamado Prompt de comando e clique em Executar como administrador.
  3. Digite os seguintes comandos em sequência:

    • cd C:\Windows\Arquivos de programas baixados
    • regsvr32 /u clientautomation.dll

  4. Clique em OK na janela de confirmação exibida, que diz: "DLLUnregisterServer em C:\Windows\Arquivos de Programa Baixados\clientautomation.dll bem-sucedido."

    • Deslocar "C:\clientAutomation\*" "C:\Windows\Arquivos de programa baixados"
    • regsvr32 clientautomation.dll

  5. Clique em OK na janela de confirmação exibida, que diz: "DLLRegisterServer em C:\Windows\Arquivos de Programa Baixados\clientautomation.dll bem-sucedido."

Após esses passos, como um requisito geral para que o ActiveX funcione corretamente, verifique se o domínio ariba.com faz parte da lista de sites confiáveis.

Siga estas etapas,

  1. No Internet Explorer, clique no ícone Ferramentas no canto superior direito e, em seguida, em Opções da Internet.
  2. Vá para a guia Segurança e selecione Sites confiáveis entre os quatro ícones na parte superior e, em seguida, clique em Sites.
  3. Verifique se algo terminando em "ariba.com" aparece na lista.Se não, adicione "https://*.ariba.com".

Depois de todas essas etapas, também é uma prática recomendada limpar o cache e os cookies do navegador, que também podem ser feitos a partir de Opções da Internet:

  1. Vá para a guia Geral.
  2. Na seção chamada Histórico de navegação, clique no botão Excluir.
  3. Entre as opções disponíveis na próxima janela, selecione apenas "Arquivos temporários da Internet e arquivos do site" e "Cookies e dados do site".
  4. Clique em OK. Em seguida, feche todas as janelas do navegador.

Agora você pode tentar novamente exportar um relatório usando um modelo do Excel ou ativar a DFS usando um dos métodos disponíveis.

Causa

O usuário não tem direitos administrativos e tem que enviar essas instruções ao departamento de TI [Tecnologia da Informação] para implementação central. Esse departamento de TI não tem acesso à plataforma Ariba para acionar a instalação automática.

O arquivo de extensão, clientautomation.dll, estava corrompido e precisava ser substituído.

Informações adicionais

No momento, a nova IU [interface do usuário] tem um pequeno problema no procedimento de ativação da DFS. Isso ocorre principalmente quando acionado pela notificação recebida ao acessar um projeto em um realm, em vez de clicar em Preferências -> Alterar sincronização de arquivo de desktop. Alguns sintomas e resoluções são:

Caso seu realm utilize Segurança aprimorada para a entrega do controle X ativo (o parâmetro Application.Base.EnableVeriSign2048CertificateAuthentication está definido como Sim), você precisará fazer o download de um arquivo diferente para a instalação.

A localização dos arquivos CAB para as duas versões é a seguinte:

Para entender se o realm está configurado dessa forma, entre em contato com seu DSC ou o Suporte ao cliente Ariba.

Guia de solução de problemas do ActiveX Control para Windows 8.1 e Windows 10 para DFS issue.zip77,15 KB

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