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ActiveX-Control-Fehlerbehebungsleitfaden für Windows 8.1 und Windows 10 für DFS-bezogene Probleme
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Problem

Das ActiveX-Steuerelement, das für die Desktop-Dateisynchronisierung (DFS) und für den Export von Berichten in eine Excel-Tabellenkalkulation verwendet wird, muss manuell installiert werden oder erfordert eine Fehlerbehebung auf dem Rechner eines Benutzers aufgrund von Fehlern.

Auflösung

Selbst ein Benutzer mit Administratorrechten auf dem Rechner kann den Inhalt des Ordners "C:\Windows\Downloaded Program Files" nicht durchsuchen. Daher müssen Sie Dateien entfernen und über die Befehlszeileneingabeaufforderung dorthin kopieren. Dies beeinträchtigt nicht die Berechtigungen und die Eigentümerschaft dieses Ordners. Um mit einer Schwachstellenbehebung fortzufahren, die in der Client-Bereinigung und der manuellen Neuinstallation besteht, führen Sie die folgenden Schritte aus:

  1. Laden Sie die Datei clientautomation.zip herunter, die dieser Seite beigefügt ist, und entpacken Sie den Inhalt auf Ihrem Laufwerk C:.
  2. Öffnen Sie Start, geben Sie "cmd" ein, klicken Sie mit der rechten Maustaste auf das Symbol mit der Bezeichnung Eingabeaufforderung, und klicken Sie auf Als Administrator ausführen.
  3. Geben Sie nacheinander die folgenden Befehle ein:

    • cd C:\Windows\Heruntergeladene Programmdateien
    • regsvr32 /u clientautomation.dll

  4. Klicken Sie im daraufhin angezeigten Bestätigungsfenster auf OK, in dem steht: "DLLUnregisterServer in C:\Windows\Downloaded Program Files\clientautomation.dll successfully."

    • Verschieben Sie "C:\clientautomation\*" "C:\Windows\Downloaded Program Files".
    • regsvr32 clientautomation.dll

  5. Klicken Sie im daraufhin angezeigten Bestätigungsfenster auf OK, in dem steht: "DLLRegisterServer in C:\Windows\Downloaded Program Files\clientautomation.dll successfully."

Nachdem Sie diese Schritte ausgeführt haben, muss ActiveX generell auch ordnungsgemäß funktionieren. Prüfen Sie, ob die Domäne ariba.com Teil der Liste der vertrauenswürdigen Sites ist.

Führen Sie die folgenden Schritte aus:

  1. Klicken Sie im Internet Explorer auf das Symbol Extras in der oberen rechten Ecke und dann auf Internetoptionen.
  2. Wechseln Sie zur Registerkarte Sicherheit, wählen Sie Vertrauenswürdige Sites unter den vier Symbolen oben aus, und klicken Sie dann auf Sites.
  3. Prüfen Sie, ob etwas, das auf "ariba.com" endet, in der Liste angezeigt wird. Wenn nicht, fügen Sie "https://*.ariba.com" hinzu.

Nach all diesen Schritten ist es auch eine Best Practice, den Cache und die Cookies des Browsers zu löschen, was auch über die Internetoptionen erfolgen kann:

  1. Wechseln Sie zur Registerkarte Allgemein.
  2. Klicken Sie im Abschnitt Browserverlauf auf die Schaltfläche Löschen.
  3. Wählen Sie unter den verfügbaren Optionen im nächsten Fenster nur "Temporäre Internetdateien und Website-Dateien" und "Cookies und Website-Daten" aus.
  4. Klicken Sie auf OK. Schließen Sie anschließend alle Browserfenster.

Nun können Sie erneut versuchen, einen Bericht entweder mithilfe einer Excel-Vorlage zu exportieren oder die Desktop-Dateisynchronisierung mit einer der verfügbaren Methoden zu aktivieren.

Ursache

Der Nutzer hat keine Administrationsrechte und muss diese Weisungen zur zentralen Bereitstellung an seine IT-Abteilung [Informationstechnologie] übermitteln. Diese IT-Abteilung hat keinen Zugriff auf die Ariba-Plattform, um die automatische Installation auszulösen.

Die Erweiterungsdatei clientautomation.dll war beschädigt und musste ersetzt werden.

Zusätzliche Informationen

Derzeit weist die neue UI [Benutzungsoberfläche] ein kleines Problem im DFS-Aktivierungsverfahren auf. Er tritt vor allem auf, wenn er durch die Benachrichtigung ausgelöst wird, die beim Zugriff auf ein Projekt in einem Bereich empfangen wird, im Gegensatz zum Klicken auf Voreinstellungen -> Desktop-Dateisynchronisierung ändern. Einige Symptome und Lösungen sind:

Wenn Ihr Bereich Enhanced Security für die Bereitstellung des Active-X-Steuerelements verwendet (der Parameter Application.Base.EnableVeriSign2048CertificateAuthentication ist auf Yes gesetzt), müssen Sie eine andere Datei für die Installation herunterladen.

Der Speicherort der CAB-Dateien für beide Versionen ist wie folgt:

Um zu erfahren, ob der Bereich so konfiguriert ist, wenden Sie sich an Ihren DSC oder den Ariba-Kundensupport.

Leitfaden zur Fehlerbehebung bei ActiveX Control für Windows 8.1 und Windows 10 für DFS im Zusammenhang mit issue.zip77,15 KB

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