Nota di supporto KB0394539
Posta elettronica
Come risolvere i problemi di acquisto nei cataloghi PunchOut?
Per comodità dell'utente, questo articolo della Knowledge Base è stato tradotto automaticamente. SAP non fornisce alcuna garanzia in merito alla correttezza o alla completezza della traduzione automatica. È possibile visualizzare il contenuto originale passando all'inglese nel selettore della lingua.
Sintomo

L'utente compratore lamenta di incontrare difficoltà durante la restituzione degli articoli acquistati all'approvvigionamento Ariba dal sito del fornitore


Causa

Il problema dovrebbe riguardare il messaggio dell'ordine PunchOut [POOM] che il fornitore invia nuovamente al sito del compratore


Soluzione

I passaggi che il supporto tecnico deve eseguire per risolvere il problema:

  1. Nella richiesta del messaggio dell'ordine PunchOut codificato all'interno del codice HTML, convalidare quanto segue:
  2. L'URL di destinazione POOM corrisponde all'URL post del modulo del browser. L'attributo che determina queste informazioni:
    ACTION=https://service.ariba.com/CatalogTester.aw/128481039/ad/handlePunchOutOrder/WOIhJPilW96Qu2jAqDrZES6etxYUweG10.273222892699825632?awr=2&u=wZVcDG59&awps=Hjuk0TbACReHArsq>
  3. Il cookie del compratore utilizzato nel POOM corrisponde a quello nella richiesta di configurazione PunchOut.
  4. Il tipo di codifica del POOM deve essere menzionato nell'attributo, NAME="cxml-urlencoded"
  5. Convalida il POOM rispetto a DTD

Di seguito sono riportati i problemi di configurazione di base che potrebbero causare l'errore di PunchOut. Per comprendere i problemi relativi ai dati, eseguire un PunchOut completo utilizzando la verifica dei cataloghi con il POOM fornito dal fornitore:

Modifiche comuni:

  1. Da, A e Mittente devono puntare al sito di prova.
  2. L'attributo azione del codice HTML deve avere lo stesso URL, che si trova nel modulo browser post URL.
  3. Il cookie del compratore nel messaggio POOM deve essere sostituito con lo stesso cookie fornito nella richiesta di configurazione PunchOut stimolata dal tester cataloghi.
  4. In base al tipo di codifica fornito nel codice HTML [Commerce eXtensible Markup Language (cXML), base 64/cXML-urlencoded], codificare il POOM di conseguenza.
  5. Salvare il messaggio POOM in formato .HTML.
  6. Una volta che l'utente visualizza il sito Web dopo aver eseguito il PunchOut, pubblicare il POOM con codifica HTML.
  7. Se il POOM ha esito positivo, dovremmo vedere che queste voci sono state pubblicate correttamente in Ariba.
  8. In caso contrario, Ariba produrrà i relativi codici di errore, confermando i problemi dei dati nel messaggio POOM, che dovranno poi essere corretti dal fornitore.


Si applica a

Gestione cataloghi > Catalogo PunchOut
Gestione cataloghi > Catalogo PunchOut > Ordinazione del catalogo PunchOut
SAP Business Network for Procurement e Supply Chain > Cataloghi > Catalogo PunchOut

Condizioni di utilizzo  |  Copyright  |  Informazioni sulla sicurezza  |  Privacy