Note d'assistance KB0394539
E-mail
Comment résoudre les problèmes d'achat de catalogue PunchOut ?
Cet article de la base de connaissances a été traduit automatiquement pour vous faciliter la tâche. SAP ne garantit pas l'exactitude ou l'exhaustivité de cette traduction automatique. Vous pouvez trouver le contenu d'origine en passant à l'anglais à l'aide du sélecteur de langue.
Symptôme

L'utilisateur acheteur se plaint des difficultés rencontrées lors du renvoi des articles achetés à l'approvisionnement Ariba depuis le site du fournisseur.


Cause

Le problème doit être lié au message de commande PunchOut [POOM] que le fournisseur republie sur le site de l'acheteur.


Résolution

Les étapes que Technical Support doit suivre pour résoudre le problème :

  1. Dans la demande de message de commande PunchOut codé dans la partie code HTML du message, validez les éléments suivants :
  2. L'URL cible POOM correspond à l'URL de publication du formulaire de navigateur. L'attribut qui détermine ces informations :
    ACTION=https://service.ariba.com/CatalogTester.aw/128481039/ad/handlePunchOutOrder/WOIhJPilW96Qu2jAqDrZES6etxYUweG10.273222892699825632?awr=2&u=wZVcDG59&awps=Hjuk0TbACReHArsq>
  3. Le cookie acheteur utilisé dans POOM correspond à celui de la demande de configuration PunchOut.
  4. Le type de codage de POOM doit être mentionné dans l'attribut, NAME="cxml-urlencoded".
  5. Valider POOM par rapport à DTD

Vous trouverez ci-dessus les problèmes de configuration de base qui peuvent être à l'origine de l'échec du PunchOut. Pour déterminer les problèmes liés aux données, effectuez un PunchOut complet à l'aide du testeur de catalogue avec le POOM fourni par le fournisseur :

Modifications courantes :

  1. De, À et Expéditeur doivent pointer vers notre site de test.
  2. L'attribut d'action du code HTML doit avoir la même URL que celle fournie dans le navigateur après l'URL.
  3. Le cookie acheteur dans le message POOM doit être remplacé par le même cookie que celui présent dans la demande de configuration PunchOut stimulée par le testeur de catalogue.
  4. En fonction du type de codage fourni dans le code HTML [cXML (Commerce eXtensible Markup Language), base 64/cXML-urlencoded], encodez le POOM en conséquence.
  5. Enregistrez le message POOM au format .HTML.
  6. Une fois que l'utilisateur a consulté le site Web après avoir effectué le PunchOut, publiez le POOM encodé en HTML.
  7. Si le POOM est réussi, nous devons voir ces articles correctement comptabilisés dans Ariba.
  8. Si ce n'est pas le cas, Ariba génère des codes d'erreur associés, confirmant les problèmes de données sur le message POOM, qui doivent ensuite être corrigés par le fournisseur.


S'applique à

Gestion de catalogue > Catalogue PunchOut
Gestion de catalogue > Catalogue PunchOut > Commande de catalogue PunchOut
SAP Business Network for Procurement & Supply Chain > Catalogues > Catalogue PunchOut

Conditions d'utilisation  |  Copyright  |  Informations sur la sécurité  |  Confidentialité