Nota de asistencia técnica KB0394539
Correo electrónico
¿Cómo solucionar problemas de compra de catálogos PunchOut?
Este artículo de la base de conocimientos ha sido traducido automáticamente para su comodidad. SAP no ofrece ninguna garantía con respecto a la exactitud o integridad de la traducción automática. Puede acceder al contenido original si cambia al inglés mediante el selector de idiomas.
Síntoma

El usuario comprador se queja de que se encuentra con dificultades al devolver los artículos comprados a Ariba Procurement desde el sitio del proveedor


Causa

El problema debería ser con el mensaje de pedido de PunchOut [POOM] que el proveedor vuelve a publicar en el sitio del comprador


Resolución

Los pasos que debe seguir el servicio de asistencia técnica en la resolución del problema:

  1. En la solicitud para el mensaje de pedido de PunchOut codificado dentro de la parte de código HTML del mensaje, valide lo siguiente:
  2. La URL de destino POOM coincide con la URL de publicación del formulario del navegador. El atributo que determina esta información:
    ACTION=https://service.ariba.com/CatalogTester.aw/128481039/ad/handlePunchOutOrder/WOIhJPilW96Qu2jAqDrZES6etxYUweG10.273222892699825632?awr=2&u=wZVcDG59&awps=Hjuk0TbACReHArsq>
  3. La cookie de comprador utilizada en el POOM coincide con la de la solicitud de configuración de PunchOut.
  4. El tipo de codificación de POOM debe mencionarse en el atributo NAME="cxml-urlencoded"
  5. Validar POOM frente a DTD

Arriba están los problemas de configuración básica que pueden ser la causa del fallo de PunchOut. Para averiguar los problemas relacionados con los datos, realice un PunchOut completo utilizando el probador de catálogos con el POOM proporcionado por el proveedor:

Modificaciones comunes:

  1. De, A y Emisor deben apuntar a nuestro sitio de pruebas.
  2. El atributo de acción del código HTML debe tener la misma URL, que viene en la URL de publicación del formulario del navegador.
  3. La cookie de comprador en el mensaje POOM debe sustituirse por la misma que aparece en la solicitud de configuración de PunchOut estimulada por el probador del catálogo.
  4. Según el tipo de codificación proporcionado en el código HTML [Commerce eXtensible Markup Language (cXML), base 64/cXML-urlencoded], codifique el POOM según corresponda.
  5. Grabe el mensaje POOM en formato .HTML.
  6. Una vez que el usuario vea el sitio web después de realizar el PunchOut, publique el POOM codificado en HTML.
  7. Si el POOM es correcto, deberíamos ver estos artículos contabilizados correctamente en Ariba.
  8. De lo contrario, Ariba produciría códigos de error relacionados, confirmando problemas de datos en el mensaje POOM, que luego debe corregir el proveedor.


Se aplica a

Gestión de catálogo > Catálogo PunchOut
Gestión de catálogo > Catálogo PunchOut > Pedido de catálogo de PunchOut
SAP Business Network for Procurement & Supply Chain > Catálogos > Catálogo PunchOut

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad