Support Note KB0394309
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Cannot Submit Signature Task for DocuSign Due to Error: "User [email address] does not have a DocuSign account. Please contact your DocuSign account administrator to add you as an authorized DocuSign user."
Issue

When submitting signature task for DocuSign, the following error is displayed:

Error from signature provider: User [user email address] does not have a DocuSign account. Please contact your DocuSign account administrator to add you as an authorized DocuSign user.

Resolution

Here are steps to create an account in DocuSign (NOTE: These steps must be performed through the user account that was configured in your Ariba DocuSign REST parameters):

  1. Login to DocuSign
  2. Click the portrait on upper right corner of the screen > select Preferences (see screenshot below)
  3. Under the Account Administration section on navigation panel on left side, click Users (see screenshot below)
  4. Click New
  5. Enter Email Address (Important: Please make sure that the email address you entered here is the same email address configured for the signature task owner in Ariba. Also, note that the user email addresses between Ariba and DocuSign is NOT case sensitive.  It can be First.Last@domain.com in Ariba and first.last@domain.com on DocuSign and it will work just fine.) and click Check Address
  6. Enter Name (required) and values for the other optional fields as desired

After this is complete, follow the nest steps:

  1. For Permission Profile, you can select DocuSign Sender
  2. Click Save then on next screen, you can choose to enter an Access Code (this is optional, if you chose to do this, you need to communicate that access code to the user separately)
  3. Click Send button
  4. User should receive an email from DocuSign with subject Account Activation 
  5. User needs to click on the Activate link from the email to activate the account

If you encountered any issue creating a new user account in DocuSign, please get in touch with DocuSign support to help with account setup issue.

Preferences:

 

Users page under Account Administration:

Cause

Each task owner that submits a task must have an account with DocuSign. This account must be registered under the same email address as the address configured for the task owner on the Ariba server.

Additional Information

Other possible causes of the error above:

  1. The user's Permission Profile in DocuSign is set to DocuSign Viewer. Change this to DocuSign Sender to resolve.
  2. An incorrect User ID and/or Password for the admin account for DocuSign is tied to SAP Ariba. Set the correct User ID/Password.

Applies To

Strategic Contracts > Contract Tasks

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