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订购单失败,出现“PO-9: cXML 响应无效”错误消息
症状

While sending a Purchase Order to SAP Business Network, my purchase order fails with the below error: PO-9: Invalid cXML response.


原因

The supplier's commerce eXtensible Markup Language (cXML) application is sending back an invalid cXML response for the order posted by Ariba.

The following is an example of an invalid cXML response:

<?xml version="1.0" encoding="UTF-8" ?><!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd"><Response>
<Status code="500" text="Unrecognised message request"/>
</Response>


解决方法
问题

订购单失败,出现PO-9: cXML 响应无效错误消息。

原因

供应商的商业可扩展标记语言 (cXML) 应用程序针对 Ariba 发布的订单发回无效的 cXML 响应。

以下是无效 cXML 响应的示例:

http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd">
  

解决方案

供应商的应用程序需要针对 Ariba 发布的订单发回有效的 200 确认。

以下是有效的 200 响应的示例:

http://xml.cXML.org/schemas/cXML/1.2.021/cXML.dtd"> <cXMLpayloadID="1232424-2001@premier.workchairs.com"xml:lang="en-CA"  timestamp="2016-10-12T18:39:42-08:00">

   

 


另请参阅

See Purchase orders are failing to reach the supplier integrated system (via cXML), but can be seen in the supplier's Inbox for a list of common similar errors and their resolution.



适用产品

SAP Business Network 采购和供应链 > 交易文档 > 交易(订购单、发货通知和货物收货记录)

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