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Pourquoi un bon de commande a échoué avec l'erreur : PO-9 : Réponse cXML non valide ?
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Symptôme

Un bon de commande envoyé à SAP Business Network échoue avec l'erreur PO-9 : Réponse cXML non valide


Environnement

SAP Business Network


Cause

L'application cXML (Commerce eXtensible Markup Language) du fournisseur renvoie une réponse cXML non valide pour le bon de commande envoyé par SAP Business Network.

Voici un exemple de réponse non valide :

< ?xml version="1.0" encoding="UTF-8" ?>< !DOCTYPE SYSTÈME cXML "http://xml.cxml.org/schemas/cXML/1.1.010/cXML.dtd"> <Réponse>
<Status code="500" text="Exemple de texte"/>
</Réponse>


Résolution

Pour garantir la réussite de la transmission des bons de commande, le système du fournisseur doit renvoyer une confirmation HTTP 200 valide lorsque SAP Business Network achemine le bon de commande.

En outre, la réponse cXML doit strictement respecter le format décrit dans la section Exemple de document de réponse du Guide des solutions cXML. Si ce format n'est pas respecté, le bon de commande peut être marqué comme Échec dans SAP Business Network.

Vous trouverez ci-dessous un exemple de réponse valide de 200 :

<?xml version="1.0" encoding="UTF-8"?>
< !DOCTYPE SYSTÈME cXML "http://xml.cXML.org/schemas/cXML/1.2.021/cXML.dtd">
<cXML payloadID="1232424-testpayloadid234525" xml:lang="en-CA" timestamp="2016-10-12T18:39:42-08:00">
<Réponse>
<Code de statut="200" text="OK"/>
</Réponse>
</cXML>

Si l'intégration cXML n'est pas requise ou est actuellement mal configurée, vous pouvez modifier la méthode d'acheminement dans SAP Business Network en accédant à : Paramètres du compte (Initiales de l'utilisateur) > Paramètres > Acheminement des commandes électroniques et en sélectionnant une autre option (par exemple, En ligne).

Une fois que l'action corrective appropriée a été prise, le fournisseur peut renvoyer le bon de commande à lui-même pour mettre à jour son statut sur Confirmé(e). Si le fournisseur est en mesure de soumettre une facture au bon de commande, le statut du bon de commande passe également à Confirmé.


Voir également

SAP Help Portal > SAP Business Network for Procurement > Guide des solutions cXML > Bons de commande > Documents de réponse

KB0404685 - Les bons de commande (BdC) ne parviennent pas au système intégré du fournisseur (via cXML), mais sont visibles dans la boîte de réception du fournisseur.

KB0558349 - Comment renvoyer un bon de commande à partir d'un compte fournisseur ?



S'applique à

SAP Business Network for Procurement & Supply Chain > Documents de transaction > Transaction (bons de commande, avis d'expédition et reçus de marchandises)

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