Nota de suporte KB0393053
E-mail
Causas comuns para imagens e miniaturas de catálogo não serem exibidas ao usar URLs
Este artigo da base de conhecimentos foi traduzido automaticamente para sua conveniência. A SAP não fornece qualquer garantia em relação à exatidão ou completude da tradução automática. Você pode encontrar o conteúdo original alternando para inglês, usando o seletor de idioma.
Sintoma

As imagens, com base em Uniform Resource Locaters (URLs), não são exibidas para itens do catálogo. Os URLs apresentam a imagem quando acessados em um navegador fora da Ariba, no entanto, as imagens não são mostradas corretamente para os itens do catálogo.


Ambiente

Catálogos SAP Ariba


Causa

Existem várias causas potenciais para este problema; as mais comuns estão listadas abaixo:

  1. O URL não termina com uma extensão de imagem válida.
  2. O certificado para o domínio que hospeda a imagem não é da confiança da Ariba.
  3. O URL redireciona para a imagem e não é, na verdade, o diretório de arquivos para o arquivo de imagem.
  4. O URL aponta para uma imagem maior que o tamanho de imagem permitido definido pela Ariba.
  5. O URL está correto, mas você não pode atualizar as imagens para todo o catálogo. As imagens carregam uma página de cada vez.
  6. Podem ocorrer determinadas situações em que itens de diferentes catálogos compartilham a mesma chave de item (SupplierID|SupplierPartID|SupplierAuxiliaryPartID). Quando a imagem for atualizada para um, ela será atualizada para o item duplicado.

Resolução

1. O URL não termina com uma extensão de imagem válida.

Para que a Ariba leia corretamente o tipo de imagem, o URL precisa fornecer a extensão de arquivo adequada no URL. Isso significaria que o URL é o diretório exato para onde o arquivo de imagem está hospedado.

2. O certificado para o domínio que hospeda a imagem não é da confiança da Ariba.

As imagens não podem ser chamadas pelo sistema Ariba quando não confiamos no certificado do domínio no URL que está sendo fornecido. Isso pode ser encontrado pelo suporte Ariba, ao habilitar o registro de imagens do catálogo. Se você tiver confirmado que as duas primeiras resoluções não resolvem o problema de exibição da imagem do catálogo, você deverá entrar em contato com o suporte Ariba para confirmar se esta é a causa do problema

3. O URL redireciona para a imagem e não é, na verdade, o diretório de arquivos para o arquivo de imagem.

O URL que está sendo fornecido pelo fornecedor em seu catálogo CIF não é o diretório real onde os itens estão localizados. O URL funciona quando colado ou digitado em um navegador; no entanto, as imagens não são mostradas corretamente na Ariba. O URL está redirecionando para a imagem, mas não para o URL real da imagem. Devido a isso, as imagens não estão aparecendo corretamente. Isso pode ser encontrado pelo suporte Ariba, ao habilitar o registro de imagens do catálogo. Se você tiver confirmado que as duas primeiras resoluções não resolvem o problema de exibição da imagem do catálogo, você deverá entrar em contato com o suporte Ariba para confirmar se esta é a causa do problema.

4. O URL aponta para uma imagem maior que o tamanho de imagem permitido definido pela Ariba.

A Ariba designou um limite de tamanho de pixel em imagens do catálogo de 500x500 pixels. Essa limitação foi implementada para impedir que o sistema armazenasse imagens excessivamente grandes na memória. Se o URL listado no arquivo do catálogo estiver apontando para uma imagem maior que o limite de 500x500 pixels, a imagem será descartada e não será aplicada ao item do catálogo. Se você tiver confirmado que as duas primeiras resoluções não resolvem o problema de exibição da imagem do catálogo, você deverá entrar em contato com o suporte Ariba para confirmar se esta é a causa do problema.

5. O URL está correto, mas você não pode atualizar as imagens para todo o catálogo. As imagens carregam uma página de cada vez.

6. Certifique-se de que cada item tenha uma chave de item única. Mais informações sobre itens duplicados podem ser encontradas neste KB0396420: Vários itens com o mesmo código de peça do fornecedor.

Verifique o status do parâmetro Application.Catalog.Search.AsyncImageDownload.
Detalhes: este valor de parâmetro determina se as imagens de catálogo remotas encontradas nos resultados da pesquisa ou durante o carregamento do catálogo são descarregadas em uma thread de plano de fundo. Quando definido como Sim, os threads de plano de fundo buscam imagens primárias e em miniatura de URLs remotos e também convertem as imagens descarregadas em miniaturas escalonadas para baixo. No caso de imagens carregadas em um pacote zip juntamente com o catálogo, este parâmetro não tem impacto.

Um sintoma claro para definir isso seria quando você clicar em um número de página, ele iniciará o download, mas uma vez que a página não é atualizada, as imagens não são exibidas até que você saia e volte para esse número de página.



Aplicável a

Gerenciamento de catálogo > Imagens de catálogo
SAP Business Network para compras e cadeia de suprimentos > Catálogos > Imagens de catálogo

Termos de uso  |  Copyright  |  Divulgação de segurança  |  Privacidade