Nota de asistencia técnica KB0393053
Correo electrónico
Causas comunes para que las imágenes de catálogo y las miniaturas no se muestren al utilizar URL
Este artículo de la base de conocimientos ha sido traducido automáticamente para su comodidad. SAP no ofrece ninguna garantía con respecto a la exactitud o integridad de la traducción automática. Puede acceder al contenido original si cambia al inglés mediante el selector de idiomas.
Síntoma

Las imágenes, basadas en Uniform Resource Locaters (URL), no aparecen para los artículos de catálogo. Las URL presentan la imagen cuando se accede a ella en un navegador fuera de Ariba, pero las imágenes no se muestran correctamente para los artículos de catálogo.


Entorno

Catálogos de SAP Ariba


Causa

Existen varias causas potenciales para este problema; las más comunes se enumeran a continuación:

  1. La URL no termina con una extensión de imagen válida.
  2. Ariba no confía en el certificado del dominio que aloja la imagen.
  3. La URL se redirige a la imagen y no es realmente el directorio de archivos al archivo de imagen.
  4. La URL apunta a una imagen que es mayor que el tamaño de imagen permitido establecido por Ariba.
  5. La URL es correcta, pero no puede actualizar las imágenes de todo el catálogo. Las imágenes cargan una página a la vez.
  6. Se pueden producir ciertos escenarios en los que los artículos de diferentes catálogos comparten la misma clave de artículo (SupplierID|SupplierPartID|SupplierAuxiliaryPartID). Cuando la imagen se actualiza para uno, se actualizará para el artículo duplicado.

Resolución

1. La URL no termina con una extensión de imagen válida.

Para que Ariba lea correctamente el tipo de imagen, la URL debe proporcionar la extensión de archivo adecuada en la URL. Esto significaría que la URL es el directorio exacto en el que se aloja el archivo de imagen.

2. Ariba no confía en el certificado del dominio que aloja la imagen.

El sistema Ariba no puede extraer imágenes cuando no confiamos en el certificado del dominio en la URL proporcionada. El servicio de asistencia de Ariba puede encontrarlo al activar el registro de imágenes de catálogo. Si ha confirmado que las dos primeras resoluciones no resuelven el problema de visualización de la imagen del catálogo, debe ponerse en contacto con el servicio de asistencia de Ariba para confirmar si esta es la causa del problema

3. La URL se redirige a la imagen y no es realmente el directorio de archivos al archivo de imagen.

La URL que proporciona el proveedor en su catálogo CIF no es el directorio real en el que se encuentran los artículos. La URL funciona cuando se pega o se escribe en un navegador; sin embargo, las imágenes no se muestran correctamente en Ariba. La URL se está redirigiendo a la imagen, pero no a la URL real de la imagen. Debido a esto, las imágenes no se muestran correctamente. El servicio de asistencia de Ariba puede encontrarlo al activar el registro de imágenes de catálogo. Si ha confirmado que las dos primeras resoluciones no resuelven el problema de visualización de la imagen del catálogo, debe ponerse en contacto con el servicio de asistencia de Ariba para confirmar si esta es la causa del problema.

4. La URL apunta a una imagen que es mayor que el tamaño de imagen permitido establecido por Ariba.

Ariba ha designado un límite de tamaño de píxeles en las imágenes del catálogo de 500x500 píxeles. Esta limitación se puso en marcha para evitar que el sistema almacenara imágenes excesivamente grandes en la memoria. Si la URL enumerada en el archivo de catálogo apunta a una imagen que supera la limitación de 500x500 píxeles, la imagen se descartará y no se aplicará al artículo de catálogo. Si ha confirmado que las dos primeras resoluciones no resuelven el problema de visualización de la imagen del catálogo, debe ponerse en contacto con el servicio de asistencia de Ariba para confirmar si esta es la causa del problema.

5. La URL es correcta, pero no puede actualizar las imágenes de todo el catálogo. Las imágenes cargan una página a la vez.

6. Asegúrese de que cada posición tenga una clave de posición unívoca. Encontrará más información sobre los artículos duplicados en este KB0396420: Varios artículos con el mismo ID de pieza de proveedor.

Verifique el estado del parámetro Application.Catalog.Search.AsyncImageDownload.
Detalles: este valor de parámetro determina si las imágenes de catálogo remotas encontradas en los resultados de búsqueda o durante la carga del catálogo se descargan en un hilo de fondo. Cuando se establece en Sí, los hilos de fondo obtienen la imagen primaria y la imagen en miniatura de las URL remotas, y también convierten las imágenes descargadas en miniaturas escaladas hacia abajo. En el caso de imágenes cargadas en un zip junto con el catálogo, este parámetro no tiene ningún impacto.

Un síntoma claro para definir esto sería cuando hace clic en un número de página que iniciará la descarga, pero como la página no se actualiza, las imágenes no se muestran hasta que salga y vuelva a ese número de página.



Se aplica a

Gestión de catálogo > Imágenes de catálogo
SAP Business Network for Procurement & Supply Chain > Catálogos > Imágenes de catálogo

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad