Nota de suporte KB0392829
E-mail
Mensagem de erro "Token expirado" ao retornar do catálogo PunchOut de um fornecedor
Sintoma

Eu recebo uma mensagem de erro Token expirado ao retornar do catálogo PunchOut de um fornecedor.


Causa

Vários cenários podem causar esse erro:

  1. O usuário está usando a porta de entrada s1-2 obsoleta para acessar a Ariba.
  2. O valor BuyerCookie da sessão da PunchOutSetupRequest (POSR) não é mantido ou é diferente na PunchOutOrderMessage (POOM) retornada pelo fornecedor.
  3. O fornecedor usa cookies cross-site, que as versões mais recentes dos navegadores Chrome e Edge estão restringindo. O projeto Chromium fez alterações na forma como os cookies são tratados no inverno de 2020. Detalhes sobre essa alteração podem ser encontrados aqui. Os usuários com uma versão do Chrome anterior à 90 podiam desabilitar os cookies samesite para evitar serem afetados; no entanto, a partir da versão 90, os cookies samesite não podem mais ser desabilitados.

Resolução

Dependendo do cenário que se aplica à sua situação, uma das seguintes ações poderá ser necessária:

  1. Se a porta de entrada s1-2 estiver obsoleta, você deverá usar a porta de entrada. O KBA a seguir contém detalhes adicionais: KB0844458.
  2. Se o valor BuyerCookie da sessão da POSR for diferente da POOM retornada pelo fornecedor, o fornecedor deverá garantir que o BuyerCookie que está enviando na POOM corresponda ao que está recebendo na POSR enviada pela Ariba. Consulte Elemento BuyerCookie para obter maiores informações.
  3. Se o fornecedor usar cookies cross-site, consulte KB0401486.


Aplicável a

Gerenciamento de catálogo
Gerenciamento de catálogo > APC
Gerenciamento de catálogo > Catálogo PunchOut > Processamento de pedidos de catálogo PunchOut

Termos de uso  |  Copyright  |  Divulgação de segurança  |  Privacidade