サポートノート KB0392829
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サプライヤのパンチアウトカタログから戻る際の「トークンが期限切れになっています。」エラーメッセージ
症状

サプライヤのパンチアウトカタログから戻る際に「トークンが期限切れになっています。」というエラーメッセージが表示されます。


原因

このエラーは複数のシナリオで発生します。

  1. バイヤーが、Ariba へのアクセスに推奨されない s1-2 フロントドアを使用しています。
  2. PunchOutSetupRequest (POSR) からのセッションの BuyerCookie 値が維持されていないか、サプライヤから返された PunchOutOrderMessage (POOM) とは異なっています。
  3. サプライヤが Chrome および Edge ブラウザで制限されているサイト越え cookie を使用しています。Chromium プロジェクトにより、2020 年の冬に cookie の処理方法が変更されました。この変更の詳細は、ここで参照できます。バージョン 90 より前の Chrome のユーザーは、影響を回避するために samesite cookie を無効化できましたが、バージョン 90 以降は samesite cookie は無効化できなくなりました。

解決

状況に該当するシナリオに応じて、以下のいずれかの処理を実行する必要がある場合があります。

  1. s1-2 フロントドアが非推奨になっている場合は、フロントドアを使用する必要があります。追加の詳細については、KBA KB0844458 を参照してください。
  2. POSR からのセッションの BuyerCookie 値がサプライヤから返された POOM とは異なる場合、サプライヤは、POOM で送信した BuyerCookie が Ariba によって送信された POSR で受信した BuyerCookie と一致することを確認する必要があります。詳細については、「BuyerCookie 要素」を参照してください。
  3. サプライヤがサイト越え cookie を使用している場合は、KB0401486 を参照してください。


該当項目

カタログ管理
カタログ管理 > APC
カタログ管理 > パンチアウトカタログ > パンチアウトカタログオーダー

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