Support Note KB0408203
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How to spot a deserialization error in a PO stuck in ordering status
Symptom

After being correctly approved and processed by the ERP system, a Purchase Requisition (PR) generates a Purchase Order (PO) that is stuck in ordering status with only the PurchaseOrderExportRequest appearing in Managed Gateway for Spend&Network.


Cause

One of the common causes for this issue is unexpected content in the payload that is received by the ERP.

Since Managed Gateway for Spend&Network does not have a error handler for this scenario, the only way to spot if this is caused by a SRT: Serialization / Deserialization failed is by accessing the ERP and looking into the SRT_MONI transaction.

The error SRT: Serialization / Deserialization failed is triggered in the deserialization process where the ABAP proxy tries to parse the XML and populate the ABAP objects. In this particular scenario, the content in the payload exceeds a specified length limitation or uses characters that are not suitable for the field in subject, triggering the error.


Resolution

In order to spot a SRT: Serialization / Deserialization failed in the ERP go through the following steps:

  1. Access transaction code SRT_MONI in the ERP.
  2. In Result Output choose Detail.
  3. In Message View choose Technical View.
  4. In Time stamp from field use the day that you PR was created.
  5. In Processing Status Group field choose Erroneous.
  6. Scroll down until you find Receiver Information > Interface Name use BuyerPurchaseOrderCreateRequest_Async_In and Execute (F8).

Now you will see a screen with all the error messages in the Web Service Utilities: Message Monitor related to the request to create a buyer Purchase Order (PO).

In order to understand which document issue the error message is correlated to, follow these steps:

  1. Click in the Erroneously Processed icon () of any line which Error Information SRT: Serialization / Deserialization failed shows.
  2. On the left-hand side of the screen look for the Message Body () element, and click on it.
  3. Now you can locate the field ---ERPORDERID to see the name of the PurchaseOrderExportRequest document in Managed Gateway for Spend&Network.
  4. In the field ----REQ_ID you will see the PR number that the error message is correlated to.

In order to see what field in the payload is triggering the error:

  1. Click in the Erroneously Processed icon () of any line which Error Information SRT: Serialization / Deserialization failed shows.
  2. Search for the field first ----ChainedException field, you will notice that there are 4 of them.
  3. The main error message is displayed in the 4th ----ChainedException in the -----Exception_Text field.

The most common types of deserialization error related to improper user data in the payload are listed below:

There are different ways to solve these issues, the most common ones are shown below:

  1. Change the order content and send it again through Managed Gateway for Spend&Network by creating a new version of the document in Buying&Invoicing.
  2. Cancel the order, and create a new one by copying the canceled one and changing the fields that exceed the limitation mentioned in the error message, and submit it again to Managed Gateway for Spend&Network .
  3. Create a custom mapping in Managed Gateway for Spend&Network in order to limit the number of characters in the specific field and then reprocess the document in Managed Gateway for Spend&Network .
Additional Information

In order to prevent it from happening again for any particular field, you can request for a customisation request. This will limit the field maximum length in the Ariba Solution, preventing it from being wrongly filled up. Please refer KB0537649 for more information regarding the customisation request.



Applies To

SAP Integration Suite Managed Gateway > Managed Gateway for Business Network SCC > Managed Gateway for Buyer Business Network SCC

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