Support Note KB0406396
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Closing orders for Adjust & Receive is not working
Issue

When I try to close the order and select Adjust and Close For Receiving, for header level close, or Adjust and Receiving, for line level close; the order will get closed for receiving, but nothing else happen, and the order is not updated to reflect the received amount/quantity. I tried to reopen & then close the order for the same option again, same behavior happened.

Resolution

To resolve this, you need to understand how adjust & close for receiving works in the background:

  1. When you click on Adjust and close for receiving , Ariba will close the current version of the order for receiving.
  2. Next, Ariba will look at the received quantities & amounts of the order.
  3. Then Ariba will try to create a new version of the Requisition, adjusting the quantities & amounts to reflect the received values.
  4. Ariba will try to submit the new requisition version.
  5. The requisition will move through the normal flow: composing, submitted, approved, ordering, till it reaches ordered status so it can be closed for receiving and move to received status.

If any of the steps 2,3,4 fail, it will look like nothing happened except for step 1; no further information will be available.

To proceed with resolving this, you will need to manually perform the actions done automatically by Adjust and close for receiving option:

  1. Close the Order For Receiving.
  2. Click Change on the Order.
  3. Change the quantity or amount to match the received quantity or amount.
  4. Submit the changed order.
  5. Move the changed order/requisition, new version, to ordered status.
  6. Close the new version of the order for receiving.

These are the steps that happen in the background when using the option to Adjust and close for receiving, and if you get a stop, with an error or anything else that would prevent you from completing those steps, then you can check the reason behind it and address it.

Cause

The cause is usually a validation error, that under normal change process would prevent the submission of a new version, e.g. a date field is in the past and the validity conditions don't allow that.

Another potential cause could be that the change button, from step 2 of the manual procedure, isn't visible. Which could indicate that a change order is not possible. The cause would not be displayed, but it's most likely related to configuration or permissions.

Additional Information

Applies To

Purchasing > Requisitioning > Requisition Import/Export

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