Support Note KB0404946
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Managed Gateway for Spend&Network Error: "CIG-PLT-04641:The incoming message is invalid with the following errors: urn:Ariba:Buyer:vsap:PurchaseOrderAsyncImportPull@ line 31 in SoapResponseParse.groovy"
Symptom

PurchaseOrderAsyncImportPull transactions are failing in my SAP Integration Suite, managed gateway for spend management and SAP Business Network transaction tracker with below error:

Error: Document Failed during HTTP/SOAP post for Customer <Buyer AN ID> - Realm Name <realm id> and received SOAP Fault Message: java.lang.Exception: java.lang.Exception: SOAP Fault :The incoming message is invalid with the following errors: urn:Ariba:Buyer:vsap:PurchaseOrderAsyncImportPull@ line 31 in SoapResponseParse.groovy. Suggested Action : For further assistance, please contact Managed Gateway for Spend&Network Support with Error Code : CIG-PLT-04641


Cause

ERPPONumber value is missing in the outbound payload in Managed Gateway for Spend&Network for PurchaseOrderAsyncImportPull documents.


Resolution

The fix for this issue varies with your Managed Gateway for Spend&Network version.

If you are on Managed Gateway for Spend&Network SP6, SP7 or SP8 versions follow below step to fix the issue:

If you are on a Managed Gateway for Spend&Network Service Pack (SP) lower than SP6 E.g. SP5, SP4, SP3, SP2 the workaround is to reprocess the original Purchase Order (PO) response which has the right SAPDocumentID from your SAP ERP system using below steps:

  1. Navigate to SRT_MONI Tcode in your SAP ERP.
  2. In selection screen, key in the fields Timestamp from, Timestamp to, Sender Information > Interface Name value as ERPToAribaBuyerResponse_Async_Out, Processing Status Group as System Error.
  3. Click Execute.
  4. Select all records with System Error and click Actions > Restart.
  5. You need to ensure the user that is used to reprocess has necessary authorizations.
  6. If the user is missing authorizations, you might receive Sequence Error while reprocessing from SRT_MONI. Please contact your internal SAP ERP basis team if you encounter any such errors while reprocessing. If your basis is also unable to help, please log an SAP OSS incident under component BC-ESI-WS-ABA-MO to resolve the Sequence Error. For instructions on creation of OSS incidents, refer to How do I create an SAP OSS incident?

See Also

You can download the actual SOAP error response sent by SAP Ariba Operational Procurement solution for this document, from Managed Gateway for Spend&Network transaction tracker (TT) using below steps:

  1. Click on the red icon () against the transaction number with FAILED status in Managed Gateway for Spend&Network TT.
  2. A screen pops up which allows you to Download the actual error message.
  3. Click Download.
  4. The body of SOAP response from SAP Ariba Operational Procurement solution in this error xml that you downloaded looks like below:

    <soapenv:Body>

    <soapenv:Fault>

    <Faultcode>Internal Server Error</Faultcode>

    <Faultstring>The incoming message is invalid with the following errors: urn:Ariba:Buyer:vsap:PurchaseOrderAsyncImportPull</Faultstring>

    <Detail>cvc-complex-type.2.4.b: The content of element 'urn:item' is not complete. One of '{"urn:Ariba:Buyer:vsap":ERPPONumber, "urn:Ariba:Buyer:vsap":NumberInCollection, "urn:Ariba:Buyer:vsap":PODeliveryDate, "urn:Ariba:Buyer:vsap":POQuantity, "urn:Ariba:Buyer:vsap":PackageInfo, "urn:Ariba:Buyer:vsap":ServiceMapKey, "urn:Ariba:Buyer:vsap":custom}' is expected.</Detail>

    </soapenv:Fault>

    </soapenv:Body>

Next, you can apply following logic to interpret the above SOAP error:



Applies To

SAP Integration Suite Managed Gateway > Managed Gateway for Procurement

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