Support Note 189499
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How to handle receipts that are failing to send to the ERP?
Issue

Receipts are created in Ariba, however, they are failing to send to the ERP (external system) due to ERP Push Errors. Some of them are negative receipts (reversal receipts) and they are failing as well.

Solution

Understanding receipt workflow:

In situations where the error cannot be fixed, we can recommend the below approaches:

Option 1:
Force Process the Receipt on Ariba, using the Force Process button on the Receipt's header. Then create the Receipt manually on ERP. This approach is the recommended one as it's simpler and straightforward.

Option 2:
If manual creation of Receipts is not allowed and conflicts with your business processes, you can try the below.

  • Force Process the stuck receipts (the one receiving ERP Push Errors).
  • Create a new Receipt that will reverse the stuck receipt: if the first receipt has quantity 1, then the reverse receipt should have quantity -1; and vice versa.
  • Ensure that the new Receipt gets an ERP Push Error as well (suggestion: marking Delivery Complete or closing the Order for receiving on the ERP, not Ariba, can help).
  • After that, the new reversal receipt should also be Force Processed.
  • This will leave the Order on Ariba with 2 receipts canceling each other out.
  • Now you need to ensure that any new receipt created will successfully flow to the ERP, then create a new Receipt.

Caution: This should be tested first as it will not be applicable if any step is missed, or if there's complex receiving performed on the Order. It is also important to understand the logic behind it and can vary based on the ERP response. For instance, if ERP accepts the negative receipt and posts it instead of sending back error, this approach cannot be followed.

Option 3:
The third approach is to edit the Receipt with ERP Push Error and set the Amount Accepted/Number Accepted as 0 and resubmit. However you should use the Close Order radio button on the Receipt as the system does not allow submitting a Receipt with 0 Qty/Amount unless you are closing the Order. Please note that you can still reopen the PO.

Caution: Do not use this approach if there are any new Receipts posted against the Order. Even if they are in Processed state and exported to ERP, system removes them. This option is also not possible if your site is enabled for Purchase Order line level closure.

Cause

Cause of the errors needs to be investigated on the ERP side as ERP is sending back the errors for some specific reason. In the case that the error is identified to be some missing information being sent (not sent in this case) from Ariba, then you will need to provide the information that the ERP is expecting to be on the Receipt.

If the error is caused by the order not being found on the ERP, ensure that the order wasn't Force Ordered or deleted on the ERP after it was sent from Ariba. Future operations aren't supported for forced orders, refer to document Order transmission and failed orders.

Additional Information

To further read about specific documentations about receiving, please refer below:


Applies To

SAP Ariba Buying and Invoicing

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