支持注释 188391
电子邮件
错误:“无法找到先前确认”
为您方便起见,此知识库文章由机器进行翻译。SAP Ariba 不会对有关机器翻译的准确性或完整性提供任何保证。您可以通过使用语言选择器切换到英语来查找原始内容。
问题

确认请求在 Cloud Integration Gateway (CIG) 中失败,并显示以下错误消息:

“错误请求”和错误代码:“400”和错误代码响应:“错误:无法找到先前确认。有关详细信息,请联系支持部门并提供错误参考号:ANERR-50000000000000002082848007。建议操作:Ariba Network 中的文档失败。如需进一步帮助,请联系 Ariba 支持并提供响应中提到的代码。CIG 支持错误代码:CIG-PLT-00644

解决方案

供应商发送的 cXML 结构错误。

如何发送 cXML 结构(不正确):

<ConfirmationHeader confirmID="XXXXXX" noticeDate="2020-05-04T08:53:30+02:00" operation="update" type="allDetail"/>
 <OrderReference orderID="XXXXXXX">
    <DocumentReference payloadID="Payload of the Purchase Order"/>
 </OrderReference>

 

应如何发送 cXML 结构(正确):

<ConfirmationHeader confirmID = "XXXXXXXX" 操作 = "update" 类型 = "detail" noticeDate = "2020-05-04T08:53:30+02:00" 版本 = "1">
 <DocumentReference payloadID="payloadID of previous order confirmation"/>
</ConfirmationHeader>
 <OrderReference orderID = "XXXXXXXX">
    <DocumentReference payloadID = "Payload of Purchase Order"/>
 </OrderReference>

 

原因

供应商未正确引用之前的订单确认 (OC) Payload 标识符或当前 OC cXML 中缺少该标识符。


适用产品

SAP Business Network

使用条款  |  版权所有  |  安全披露  |  隐私