Nota de suporte 188391
E-mail
Erro: "Não é possível encontrar a confirmação anterior"
Este artigo da base de conhecimentos foi traduzido automaticamente para sua conveniência. A SAP não fornece qualquer garantia em relação à exatidão ou completude da tradução automática. Você pode encontrar o conteúdo original alternando para inglês, usando o seletor de idioma.
Problema

A solicitação de confirmação está falhando no Cloud Integration Gateway (CIG) com a mensagem de erro a seguir:

"Solicitação incorreta" e código de erro:"400" e resposta de código de erro:"Erro:Não é possível encontrar a confirmação anterior. Entre em contato com o suporte e informe o número de referência do erro: ANERR-50000000000000002082848007 para obter mais detalhes. Ação sugerida: falha do documento no Ariba Network. Para obter mais ajuda, entre em contato com o suporte da Ariba com o código mencionado em Response.Código de erro do suporte do CIG: CIG-PLT-00644

Resolução

A estrutura cXML enviada pelo fornecedor está incorreta.

Como a estrutura cXML está sendo enviada (Incorreto):

<ConfirmationHeader confirmID="XXXXXX" noticeDate="2020-05-04T08:53:30+02:00" operation="update" type="allDetail"/>
 <OrderReference orderID="XXXXXXX">
        <DocumentReference payloadID="payload do pedido"/>
 </OrderReference>

 

Como a estrutura cXML deve ser enviada (correta):

<ConfirmationHeader confirmID = "XXXXXXXX" operation = "update" type = "detail" noticeDate = "2020-05-04T08:53:30+02:00" version = "1">
 <DocumentReference payloadID="payloadID da confirmação do pedido anterior"/>
</ConfirmationHeader>
 <OrderReference orderID = "XXXXXXXX">
        <DocumentReference payloadID = "payload do pedido"/>
 </OrderReference>

 

Causa

O fornecedor não se refere corretamente ao código de payload da confirmação do pedido (OC) anterior ou está em falta no cXML da confirmação do pedido atual.


Aplicável a

SAP Business Network

Termos de uso  |  Copyright  |  Divulgação de segurança  |  Privacidade