サポートノート 188391
電子メール
エラー: "前の確認が見つかりません"
このナレッジベース記事は、お客様の利便性のために機械翻訳されています。SAP は、この機械翻訳の正確性または完全性に関して、いかなる保証も行うものではありません。言語選択で英語に切り替えると、元のコンテンツを確認できます。
問題

Cloud Integration Gateway (CIG) で確認申請が失敗し、以下のエラーメッセージが表示されます。

"不正な要求"、エラーコード:"400"、およびエラーコード応答:"エラー: 前の確認が見つかりません。詳細については、エラー参照番号 ANERR-5000000000000000002082848007 を控えてサポートまでお問い合わせください。提案された処理: ドキュメントが Ariba Network で失敗しました。サポートが必要な場合は、Response.CIG サポートエラーコード: CIG-PLT-00644 に記載されているコードを使用して Ariba サポートに連絡してください。

解決

サプライヤから送信された cXML 構造が間違っています。

cXML 構造の送信方法 (不適切):

<ConfirmationHeader confirmID="XXXXXX" noticeDate="2020-05-04T08:53:30+02:00" operation="update" type="allDetail"/>
 <OrderReference orderID="XXXXXXX">
    <DocumentReference payloadID="purload of the Purchase Order"/>
 </OrderReference>

 

cXML 構造の送信方法 (正解):

<ConfirmationHeader confirmID = "XXXXXXXX" operation = "update" type = "detail" noticeDate = "2020-05-04T08:53:30+02:00" version = "1">
 <DocumentReference payloadID="payloadID of previous order confirmation"/>
</ConfirmationHeader>
 <OrderReference orderID = "XXXXXXXX">
    <DocumentReference payloadID = "purload of Purchase Order"/>
 </OrderReference>

 

原因

サプライヤが以前のオーダー確認 (OC) ペイロード ID を正しく参照していないか、または現在の OC cXML にありません。


該当項目

SAP Business Network

使用条件  |  Copyright  |  セキュリティに関する情報  |  情報の保護