Nota di supporto 188391
Posta elettronica
Errore: "Impossibile trovare la conferma precedente"
Per comodità dell'utente, questo articolo della Knowledge Base è stato tradotto automaticamente. SAP non fornisce alcuna garanzia in merito alla correttezza o alla completezza della traduzione automatica. È possibile visualizzare il contenuto originale passando all'inglese nel selettore della lingua.
Problema

La richiesta di conferma non riesce in Cloud Integration Gateway (CIG) con il seguente messaggio di errore:

"Richiesta errata" e codice di errore:"400" e risposta codice di errore:"Errore: Impossibile trovare la conferma precedente. Per ulteriori dettagli, contattare il supporto specificando il numero di riferimento errore: ANERR-50000000000000002082848007. Azione suggerita: documento non riuscito in Ariba Network.Per ulteriore assistenza, contattare il Supporto Ariba indicando il codice menzionato in Response.Codice di errore del supporto CIG: CIG-PLT-00644

Risoluzione

La struttura cXML inviata dal fornitore è errata.

Modalità di invio della struttura cXML (errato):

<ID conferma testata="XXXXXX" noticeDate="2020-05-04T08:53:30+02:00" operation="update" type="allDetail"/>
 <OrderReference orderID="XXXXXXX">
    <DocumentReference payloadID="payload of the Purchase Order"/>
 </OrderReference>

 

Modalità di invio della struttura cXML (correzione):

<ID conferma testata = operazione "XXXXXXXX" = tipo "aggiornamento" = "dettaglio" noticeDate = "2020-05-04T08:53:30+02:00" versione = "1">
 <DocumentReference payloadID="payloadID della conferma d'ordine precedente"/>
</ConfirmationHeader>
 <OrderReference orderID = "XXXXXXXX">
    <ID payloadID riferimento documento = "payload dell'ordine d'acquisto"/>
 </OrderReference>

 

Causa

Il fornitore non fa riferimento correttamente all'ID payload della conferma d'ordine precedente o non è presente nel cXML di conferma ordine corrente.


Si applica a

SAP Business Network

Condizioni di utilizzo  |  Copyright  |  Informazioni sulla sicurezza  |  Privacy