Note d'assistance 188391
E-mail
Erreur : "Confirmation précédente introuvable"
Cet article de la base de connaissances a été traduit automatiquement pour vous faciliter la tâche. SAP ne garantit pas l'exactitude ou l'exhaustivité de cette traduction automatique. Vous pouvez trouver le contenu d'origine en passant à l'anglais à l'aide du sélecteur de langue.
Problème

La demande de confirmation échoue dans Cloud Integration Gateway (CIG) avec le message d'erreur ci-dessous :

« Requête incorrecte », Code d'erreur : « 400 » et Réponse au code d'erreur : « Erreur : La confirmation précédente est introuvable. Contactez l'assistance en indiquant le numéro de référence de l'erreur : ANERR-50000000000000002082848007 pour plus de détails. Action suggérée : échec du document dans Ariba Network. Pour obtenir de l'aide, contactez l'assistance Ariba avec le code indiqué dans Réponse.Code d'erreur d'assistance CIG : CIG-PLT-00644

Résolution

La structure cXML envoyée par le fournisseur est erronée.

Mode d'envoi de la structure cXML (incorrect) :

<ConfirmationHeader confirmID="XXXXXX" NotieDate="2020-05-04T08:53:30+02:00" operation="update" type="allDetail"/>
 <OrderReference orderID="XXXXXXX">
        <DocumentReference payloadID="payload of the Purchase Order"/>
 </OrderReference>

 

Mode d'envoi de la structure cXML (Correct) :

<ConfirmationHeader confirmID = "XXXXXXXX" operation = "update" type = "detail" notieDate = "2020-05-04T08:53:30+02:00" version = "1">
 <DocumentReference payloadID="payloadID de la confirmation de commande précédente"/>
</ConfirmationHeader>
 <OrderReference orderID = "XXXXXXXX">
        <ID de données utiles DocumentReference = "données utiles de la commande d'achat"/>
 </OrderReference>

 

Cause

Le fournisseur ne renvoie pas correctement l'ID de données utiles de confirmation de commande précédent ou il est manquant dans la confirmation de commande cXML actuelle.


S'applique à

SAP Business Network

Conditions d'utilisation  |  Copyright  |  Informations sur la sécurité  |  Confidentialité