Note d'assistance 188391
E-mail
Erreur : "Confirmation précédente introuvable"
Cet article de la base de connaissances a été traduit automatiquement pour vous faciliter la tâche. SAP ne garantit pas l'exactitude ou l'exhaustivité de cette traduction automatique. Vous pouvez trouver le contenu d'origine en passant à l'anglais à l'aide du sélecteur de langue.
Problème

La demande de confirmation échoue dans Cloud Integration Gateway (CIG) avec le message d'erreur suivant :

"Demande incorrecte" et code d'erreur :"400" et réponse de code d'erreur :"Erreur : confirmation précédente introuvable. Contactez l'assistance en indiquant la référence d'erreur ANERR-50000000000000002082848007 pour plus de détails. Action suggérée : Échec du document dans Ariba Network. Pour obtenir de l'aide, contactez l'assistance Ariba avec le code indiqué dans la réponse.Code d'erreur de l'assistance CIG : CIG-PLT-00644

Résolution

La structure cXML envoyée par le fournisseur est erronée.

Mode d'envoi de la structure cXML (Incorrect) :

<ConfirmationHeader confirmID="XXXXXX" aperçeDate="2020-05-04T08:53:30+02:00" operation="update" type="allDetail"/>
 <OrderReference orderID="XXXXXXX">
        <DocumentReference payloadID="payload of the Purchase Order"/>
 </OrderReference>

 

Mode d'envoi de la structure cXML (Correct) :

<ConfirmationHeader confirmID = "XXXXXXXX" opération = "update" type = "detail" aperçeDate = "2020-05-04T08:53:30+02:00" version = "1">
 <DocumentReference payloadID="payloadID de la confirmation de commande précédente"/>
</ConfirmationHeader>
 <OrderReference orderID = "XXXXXXXX">
        <ID de données utiles DocumentReference = "données utiles de la commande d'achat"/>
 </OrderReference>

 

Cause

Le fournisseur ne fait pas correctement référence aux données utiles de la confirmation de commande précédente ou il est manquant dans la confirmation de commande cXML actuelle.


S'applique à

SAP Business Network

Conditions d'utilisation  |  Copyright  |  Informations sur la sécurité  |  Confidentialité