Nota de asistencia técnica 188391
Correo electrónico
Error: "No se ha encontrado la confirmación anterior"
Este artículo de la base de conocimientos ha sido traducido automáticamente para su comodidad. SAP no ofrece ninguna garantía con respecto a la exactitud o integridad de la traducción automática. Puede acceder al contenido original si cambia al inglés mediante el selector de idiomas.
Problema

La solicitud de confirmación falla en Cloud Integration Gateway (CIG) con el siguiente mensaje de error:

"Solicitud incorrecta" y código de error:"400" y respuesta de código de error:"Error:No se puede encontrar la confirmación anterior. Póngase en contacto con el servicio de asistencia con el número de referencia del error: ANERR-50000000000000002082848007 para obtener más detalles. Acción sugerida : Documento fallido en Ariba Network.Para obtener ayuda, póngase en contacto con el servicio de asistencia de Ariba con el código mencionado en Respuesta.Código de error de soporte CIG: CIG-PLT-00644

Resolución

La estructura cXML enviada por el proveedor es incorrecta.

Cómo se envía la estructura cXML (Incorrecto):

<ConfirmationHeader confirmID="XXXXXX" notieDate="2020-05-04T08:53:30+02:00" operation="update" type="allDetail"/>
 <OrderReference orderID="XXXXXXX">
    <DocumentReference payloadID="payload of the Purchase Order"/>
 </OrderReference>

 

Cómo se debe enviar la estructura cXML (correcto):

<ConfirmationHeader confirmID = "XXXXXXXX" operación = tipo "actualización" = "detalle" notieDate = "2020-05-04T08:53:30+02:00" versión = "1">
 <DocumentReference payloadID="payloadID of anterior order Confirmation"/>
</ConfirmationHeader>
 <OrderReference orderID = "XXXXXXXX">
    <DocumentReference payloadID = "payload of Purchase Order"/>
 </OrderReference>

 

Causa

El proveedor no hace referencia correctamente al ID de carga útil de confirmación de pedido (OC) anterior o falta en el cXML de OC actual.


Se aplica a

SAP Business Network

Condiciones de uso  |  Copyright  |  Declaración de seguridad  |  Privacidad