Support Note 188391
Email
Error: "Previous confirmation can not be found"
Issue

Confirmation Request is failing in Cloud Integration Gateway (CIG) with the below error message:

"Bad Request" and Error Code:"400" and Error Code Response:"Error:Previous confirmation can not be found. Please contact support with the Error Reference Number: ANERR-50000000000000002082848007 for more details. Suggested Action : Document Failed in Ariba Network.For further assistance, please contact Ariba Support with the code mentioned in Response.CIG Support Error Code : CIG-PLT-00644

Resolution

The cXML structure sent by supplier is wrong.

How the cXML structure is being sent (Incorrect):

<ConfirmationHeader confirmID="XXXXXX" noticeDate="2020-05-04T08:53:30+02:00" operation="update" type="allDetail"/>
 <OrderReference orderID="XXXXXXX">
    <DocumentReference payloadID="payload of the Purchase Order"/>
 </OrderReference>

 

How the cXML structure should be sent (Correct):

<ConfirmationHeader confirmID = "XXXXXXXX" operation = "update" type = "detail" noticeDate = "2020-05-04T08:53:30+02:00" version = "1">
 <DocumentReference payloadID="payloadID of previous order confirmation"/>
</ConfirmationHeader>
 <OrderReference orderID = "XXXXXXXX">
    <DocumentReference payloadID = "payload of Purchase Order"/>
 </OrderReference>

 

Cause

Supplier is not referring the previous Order Confirmation (OC) payload ID correctly or it is missing in the current OC cXML.


Applies To

SAP Business Network

Terms of Use  |  Copyright  |  Security Disclosure  |  Privacy