Support-Hinweis 188391
E-Mail
Fehler: "Vorherige Bestätigung kann nicht gefunden werden"
Dieser Wissensdatenbankartikel wurde maschinell übersetzt. SAP übernimmt keine Gewährleistung für die Richtigkeit oder Vollständigkeit der Maschinenübersetzung. Sie können den Originalinhalt anzeigen, indem Sie über die Sprachauswahl zu "Englisch" wechseln.
Problem

Die Bestätigungsanforderung schlägt im Cloud Integration Gateway (CIG) mit der folgenden Fehlermeldung fehl:

"Bad Request" und Fehlercode:"400" und Fehlercodeantwort:"Fehler: Vorherige Bestätigung kann nicht gefunden werden. Wenden Sie sich unter Angabe der Fehlerreferenznummer ANERR-50000000000000002082848007 an den Support, um weitere Informationen zu erhalten. Vorgeschlagene Aktion: Dokument in Ariba Network fehlgeschlagen. Wenden Sie sich an den Ariba-Support, um weitere Unterstützung zu erhalten. Wenden Sie sich mit dem in Antwort genannten Code an den CIG-Support-Fehlercode: CIG-PLT-00644

Auflösung

Die vom Lieferanten gesendete cXML-Struktur ist falsch.

Wie die cXML-Struktur gesendet wird (falsch):

<ConfirmationHeader ConfirID="XXXXXX" noteeDate="2020-05-04T08:53:30+02:00" operation="update" type="allDetail"/>
 <OrderReference orderID="XXXXXXX">
        <DocumentReference payloadID="Payload der Bestellung"/>
 </OrderReference>

 

Wie die cXML-Struktur gesendet werden soll (korrekt):

<ConfirmationHeader ConfirID = "XXXXXXXX" Vorgang = "update" type = "detail" notieDate = "2020-05-04T08:53:30+02:00" version = "1">
 <DocumentReference payloadID="payloadID der vorherigen Bestellungsbestätigung"/>
</ConfirmationHeader>
 <Auftragsreferenzauftrags-ID = "XXXXXXXX">
        <DocumentReference payloadID = "Payload der Bestellung"/>
 </OrderReference>

 

Ursache

Der Lieferant verweist nicht korrekt auf die vorherige Bestellungsbestätigungs-Nutzlast-ID oder sie fehlt in der aktuellen Bestellungsbestätigungs-cXML.


Gilt für

SAP Business Network

Nutzungsbedingungen  |  Copyright  |  Sicherheitsrichtlinie  |  Vertraulichkeit