Nota di supporto 186292
Posta elettronica
Errore: "400-4XX -> Problema di autenticazione,Forbidden,Non trovato -> Controllare che il sistema di destinazione abbia fornito dettagli di autenticazione validi in CIG"
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Problema

Durante la replica dei dati di anagrafica di sourcing da SAP ERP ad Ariba Sourcing tramite Cloud Integration Gateway (CIG) ricevo il seguente errore:

Documento non riuscito durante il post HTTP per il cliente XXXXXXXXX-T - Nome realm 111111 con codice di risposta HTTP :500 e messaggio di risposta: NON RIUSCITO. Azione suggerita: pubblicazione HTTP nel sistema di destinazione non riuscita e messaggio di risposta precedente ricevuto. Risposta di errore HTTP comune e relative azioni suggestive. 500 -> Errore interno del server -> Controllare nel sistema di destinazione l'esatta natura dell'errore di richiesta. 400-4XX -> Problema di autenticazione, proibizione,Non trovato -> controllare il sistema di destinazione fornito di dettagli di autenticazione validi in CIG o il servizio di destinazione è disponibile, il servizio di sistema di destinazione ha dichiarato l'ACL corretto. Codice errore CIG: CIG-PLT-04640

Risoluzione

Assicurarsi di inviare l'ID sistema e l'ID realm corretti nel payload, ad esempio:

<Nome parametro="realm">
<value>customer_realm</value>
</Parametro>
<Nome parametro="IDsistema">
<value>ERPCLNT123 </value>
</Parametro>
<Nome parametro="Soluzione">
<value>Sourcing</value>
</Parametro>
<Nome parametro="SystemId">
<value>ERPCLNT123</value>
</Parametro>

È possibile verificare la presenza di un nome realm corretto nella tabella ARBCIG_AUTHPARAM.

Causa

Questo errore si verifica perché l'ID sistema ERP è stato inviato come nome realm nel parametro ID realm. Poiché l'ID sistema ERP non è un nome realm valido, l'integrazione non riesce a trovare il rispettivo endpoint.

Informazioni supplementari

Questo è spiegato nella SAP Ariba Cloud Integration Gateway overview guide (Guida alla panoramica di SAP Ariba Cloud Integration Gateway).


Si applica a

SAP Ariba Strategic Sourcing Suite

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