Support Note KB0400979
Email
Error: "Failed to resolve endpoint: not found in Partner Directory" in SAP Business Network with Managed Gateway for Spend&Network
Symptom

The below error is observed in Managed Gateway for Spend&Network's Transaction tracker when replicating documents from SAP Business Network:

Failed to resolve endpoint: xslt://pd:HCIOWNERPID:MAPPING_ANY_cXML_0000_DocumentType_AddOn_ARBCI10001_DocumentType%20MAPPING_ANY_cXML_0000_DocumentType_AddOn_0000_DocumentType:Binary?output=bytes&saxon=true&saxonExtensionFunctions=%23xsltExtensionsV11&uriResolverFactory=%23xsltUriResolverFactory due to: Resource 'pd:HCIOWNERPID:MAPPING_ANY_cXML_0000_DocumentType_AddOn_ARBCI10001_DocumentType MAPPING_ANY_cXML_0000_DocumentType_AddOn_0000_DocumentType:Binary' not found in Partner Directory


Environment

Managed Gateway for Spend&Network


Cause

The endpoint is not correctly configured in SAP Business Network, leading to a message sent to Managed Gateway for Spend&Network without the correct header content. The data configured in Managed Gateway for Spend&Network's Basic Data does not match, so the payload is not processed.


Resolution
  1. Log in SAP Business Network.
  2. Click Administration.
  3. Click Configuration > Business Application IDs and End Points (cXML and OData Setup).
  4. Check if the default endpoint configured for Managed Gateway for Spend&Network matches the destination ERP system ID.


Applies To

SAP Integration Suite Managed Gateway > Managed Gateway for Business Network

Terms of Use  |  Copyright  |  Security Disclosure  |  Privacy