Support Note KB0400868
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CMS content document in Validation Error status due to internal errors
Issue

A Content Management System (CMS) content document is in Validation Error status. When choosing Action > View summary next to the content document, I see the following message:

Items that failed rule execution on account of an internal error

Resolution

To find out more details about the internal error:

  1. Choose Manage > Core Administration.
  2. Go to Catalog Content Manager > Content Documents.
  3. Open your Internet browser's dev tools to the Network tab.
  4. Click Action > Edit content next to the content document with errors.
  5. In the Network tab of your browser's dev tools, click the last request, which looks something like this:

    https://s1.ariba.com/Buyer/contentmgr/tenant/buyer.1234/contentdocs/QUFSVDJfZ/contentdocumentitem?typeName=&startPg=1&pageSize=10&realm=buyer.1234&locale=en_US&dateTimeFormat=MM/dd/yyyy&cmsst=OVBIQWs2OXFLWDZGV

  6. Click the Response tab for this request.
  7. Select the whole response, and copy it into a text editor, such as Notepad++.
  8. Search for error in the file.

Sample error:

"ItemNumber": 1,
"FieldEvents": {
"All": [
{
"status": 1,
"description": "All Validation Rules",
"ruleId": "All",
"message": null
},
{
"status": 3,
"description": "System Error: Invalid field path: plantgroup",
"ruleId": "All/Any Rule",
"message": null
}
]
}

To resolve the issue, address the cause of the error by updating your validation rules or catalog files.

Cause

A hidden validation error causes the catalog content document not to pass validation.


Applies To

Catalog Management > Content Management System

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