サポートノート 184224
電子メール
エラー: "サプライヤ名がありません"
このナレッジベース記事は、お客様の利便性のために機械翻訳されています。SAP は、この機械翻訳の正確性または完全性に関して、いかなる保証も行うものではありません。言語選択で英語に切り替えると、元のコンテンツを確認できます。
問題

Cloud Integration Gateway (CIG) 経由で送信された注文書 (PO) にルーティングの詳細が含まれておらず、以下のエラーメッセージが表示されて失敗します。

"不正な要求"、エラーコード:"400"、およびエラーコード応答: エラー: サプライヤ名がありません。詳細については、エラー参照番号 ANERR-40000000000000001277504940 を控えてサポートまでお問い合わせください。提案された処理: ドキュメントは Ariba Network で処理エラーとなりました。サポートが必要な場合は、回答に記載されているコードを使用して Ariba サポートに連絡してください。CIG サポートエラーコード: CIG-PLT-00644。

解決

注文書 IDoc のルーティングの詳細は、Ariba の拡張セグメントで提供されます。お客様は ERP に Exit を実装していなかったため、ソースドキュメントには Ariba の拡張セグメントが含まれていませんでした。元伝票にはデータがないため、同じものがターゲットにも渡されず、購買発注が失敗していました。

原因

購買発注のカスタマ Exit を実装する方法のステップに従って、購買発注のカスタマ Exit を実装することができます。


該当項目

SAP Business Network

使用条件  |  Copyright  |  セキュリティに関する情報  |  情報の保護