Support Note KB0397721
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Connection error with AN adapter - Cannot connect to Ariba SNcom.ariba.asc.connector.exception.AribaSNException: Cannot connect to Ariba SN- Caused by: java.net.ConnectException: Connection timed out: connect
Issue

Connection issue in standard AN adapter , while pulling the documents from pending queue, below is the error from cxml sender debug logs in PI 

Connection time out:

#2.0 #2017 12 06 16:55:16:257#+00#Error#$Id:aribaplatformintegrationcXMLConnectorascadapterreleasecore2.42.1+comaribaascconnectorexceptionutilExceptionMgr.java\#1$#

##ariba.com/com.ariba.asc.sap.netweaver.xiadapter.ra#C0000A11C911002B000A952F00001A24#607095650000000785##$Id:aribaplatformintegrationcXMLConnectorascadapterreleasecore2.42.1+comaribaascconnectorexceptionutilExceptionMgr.java\#1$.handleError(Exception e, ChannelProfile cp)#deploy_service#0##60879527D8AA11E7BE440000242F8B62#60879527d8aa11e7be440000242f8b62#60879527d8aa11e7be440000242f8b62#0#Application [69]#Plain##

[CC_Invoice02_cXML_Sender]  [Error Level] 2[Error Code] ECC103[Error Desc] Ariba SN Not Available[Error Message] Cannot connect to Ariba SNcom.ariba.asc.connector.exception.AribaSNException: Cannot connect to Ariba SN

                at com.ariba.asc.connector.cxml.util.CXMLSender.sendRequest(CXMLSender.java:252)

                at com.ariba.asc.connector.cxml.util.CXMLSender.sendCXMLRequest(CXMLSender.java:157)

                at com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.sendProfileRequest(ProfileUpdateAction.java:192)

                at com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.updateProfile(ProfileUpdateAction.java:165)

                at com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.updateChannelProfile(ProfileUpdateAction.java:123)

                at com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ProfileUpdateAction.perform(ProfileUpdateAction.java:79)

                at com.ariba.asc.sap.netweaver.xicore.connector.controller.tasks.ScheduleTaskMgr.run(ScheduleTaskMgr.java:151)

                at com.sap.engine.core.thread.impl3.ActionObject.run(ActionObject.java:37)

                at java.security.AccessController.doPrivileged(Native Method)

                at com.sap.engine.core.thread.impl3.SingleThread.execute(SingleThread.java:185)

                at com.sap.engine.core.thread.impl3.SingleThread.run(SingleThread.java:302)

Caused by: java.net.ConnectException: Connection timed out: connect

                at java.net.PlainSocketImpl.socketConnect(Native Method)

                at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:382)

                at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:241)

                at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:228)

                at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:365)

                at java.net.Socket.connect(Socket.java:529)

                at com.sun.net.ssl.internal.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:570)

                at com.sun.net.ssl.internal.ssl.SSLSocketImpl.<init>(SSLSocketImpl.java:412)

                at com.sun.net.ssl.internal.ssl.SSLSocketFactoryImpl.createSocket(SSLSocketFactoryImpl.java:123)

                at com.ariba.asc.connector.cxml.util.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:95)

                at com.ariba.asc.connector.cxml.util.SSLProtocolSocketFactory.createSocket(SSLProtocolSocketFactory.java:163)

                at org.apache.commons.httpclient.HttpConnection.open(HttpConnection.java:704)

                at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:384)

                at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:170)

                at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:396)

                at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:324)

                at com.ariba.asc.connector.cxml.util.CXMLSender.sendRequest(CXMLSender.java:200)

                ... 10 more

 

  1. We see a Profile Request being triggered from AN sender adapter from the logs ,this  is the initial authentication step, see above. And there is an “Connection time out” after this. 
Cause

This connection time out in most cases is because of Network issues between customer's PI server and AN.

Solution

Customer needs to first test the connection to service.ariba.com from their PI OS server level to see if they are able to access the server.

Below is a way customer can test the connection from your PI server ( OS level)

  1. Command to be used : openssl s_client -state -connect service.ariba.com:443
    Note: You need to have openSSL installed in your PI server to do this test , you may contact your Network team for more details on this.
    You should see the following in case of success

In case of error, you get an error like below( sample). This means your SAP PI server is not able to reach Ariba Network and you need to check with your network team further on this , this is more of a network issue rather than AN adapter issue.

 

 

 

  1. Telnet test:

    Telnet can be used as an alternate test, but no output will be shown in case of success.

 

telnet service.ariba.com 443

 

In case of success (no error message). Cursor will be blinking.

 

In case of error (network issue)

 

Thus, please check the connection to AN from your PI server , if it doesn’t work as explained above from your OS level, it means the issue is with customer's Network and not with the  AN adapter . Customer needs to check further with your network team in case of network issues .

Additional Information

TCP port 443 to service.ariba.com which resolves to 216.109.104.11.  

The IP Address for service.ariba.com is 216.109.104.11.

In addition to that, please find below the IP Ranges supported by Ariba:

 

URL:

https://support.ariba.com/item/view/82001

 

Ariba Connect URL:

https://support.ariba.com/item/view/82001 

 

Note: Customer confirmed that they were not able to telnet service.ariba.com when they faced this issue which proved that issue was with Customer Network from their PI server , they worked with their internal network team to open the connections , after which the connection started to work. This is a Network issue that needs to be resolved by customer .


Applies To

SAP Business Network for Procurement & Supply Chain

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