Support Note KB0397268
Email
Why can I not see External System Integration fields in Sourcing and/or Contracts Projects?
Symptom

Why can I not see External System Integration fields in Sourcing and/or Contracts Projects?


Cause

There is no External System ID of type ECC or S4HANA created in the site.

Earlier, the External System Integration fields appeared by default in Sourcing Request, Sourcing Project, Contract Request, and Contract Workspace User Interface (UI). With the introduction of a Common Type system ID used for internal Master Data Sync, these fields started to appear in all customer realms.

Sourcing projects and Contract workspaces only show External System Integration fields if the site has an SAP (ECC) external system configured for master data integration. If you would like to opt to create an external system of type S4HANA, you can do so but will need to change the visibility/editability conditions in Field Configuration to remove the piece of the condition that calls for "SAPECC".equals(BusinessSystem.Type) as a requirement.

The field External System will only be visible if you have more than one External System configured for your realm, regardless of the type.


Resolution

To create SAP (ECC) external system in your site:

  1. Sign in as Customer Administrator or Master Data Manager
  2. Click Manage > Administration > Master Data manager > External System Configuration
  3. Click Create New
  4. Specify a Name and ID (Example: Default)
  5. Click Save

The Name of the External System can be edited and also the external system can be deactivated at any point of time.


See Also

You should not be deactivating the External System of type Common which is identified by your realm name. You can activate / deactivate other types of External System based on client's requirement



Applies To

Strategic Contracts
Strategic Sourcing

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