支持注释 167094
电子邮件
错误:PO-11:无法传送订单。PO 状态的终端错误代码:无法解析文档
为您方便起见,此知识库文章由机器进行翻译。SAP Ariba 不会对有关机器翻译的准确性或完整性提供任何保证。您可以通过使用语言选择器切换到英语来查找原始内容。
问题

订购单 (PO) 无法到达供应商集成系统。Ariba Network 中的 PO 历史记录 选项卡显示以下错误消息:

错误:PO-11:无法传送订单。PO 状态的终端错误代码:无法解析文档?

解决方案

供应商需要与其 IT 和集成团队进行内部审阅,以了解他们发送无效 cXML 响应的原因。对于不在 Ariba Network 中标记为失败的订购单,供应商的集成系统需要发送回成功的 200 状态代码。

解决该问题后,供应商可以从其 Ariba Network 帐户重新发送失败的订单。

原因

供应商的首选订单传送方法设置为 cXML,其集成系统返回无效的 cXML 响应。

其中一个示例是无效的 cXML 响应,其中整个 PO cXML 随响应一起发送回: 

<响应>
<Status code="500" text="PO item price: 0.0 与报价价格不匹配:191”
</响应>
附加信息

请参阅以下正确 cXML 响应的示例:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID="994994" xml:lang="en" timestamp="2002-03-12T18:39:09-08:00">
<响应>
<状态代码="200" text="OK"/>
</响应>
</cXML>

有关 cXML 集成的其他信息,请参阅《 cXML 解决方案指南 》

有关常见类似错误及其解决情况的列表,请参阅此常见集成错误列表


适用产品

SAP Business Network

使用条款  |  版权所有  |  安全披露  |  隐私