Nota di supporto 166720
Posta elettronica
Errore: "Errore di autenticazione: Autenticazione non riuscita".
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Problema

Quando tento di accedere utilizzando Single Sign-On (SSO), ricevo l'errore: Errore di autenticazione - Autenticazione non riuscita.

Il registro degli errori mostra Impossibile ottenere l'ID nome. Stack: ariba.util.saml.SAMLException: impossibile trovare NameId.

Il certificato del profilo del sito corrisponde al certificato nella risposta SAML (Security Assertion Markup Language) del cliente.

Risoluzione

Assicurarsi di inviare una voce <NameID></NameID>  nell’oggetto della risposta Security Assertion Markup Language (SAML) e non una voce <Attribute></Attribute>.

Causa

Ciò è causato da una risposta SAML non valida dopo che SAP Ariba ha richiesto informazioni sul NameID. Quando Ariba invia una richiesta SAML per l'autenticazione, sebbene un NameID venga visualizzato nella risposta, viene inviato come attributo anziché come oggetto.

Informazioni supplementari

Se si riceve l'errore Errore di autenticazione: convalida dell'utente non riuscita, vedere Certificato scaduto o Condizione non soddisfatta.


Si applica a

SAP Ariba Buying and Invoicing
SAP Ariba Buying
SAP Ariba Contracts
SAP Ariba SIPM
SAP Ariba Sourcing
SAP Ariba Spend Analysis
SAP Ariba Strategic Sourcing Suite
SAP Ariba Supplier Information Management

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