Support Note KB0395300
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SAP Data Refresh causing Integration Issue - Update of PR/PO/RC Number Range required
Symptom

Note: Applicable only for ERP integrated sites.

Customers refresh their production data to the test systems from time to time. In short, their test data is overwritten with production data. When a new document is created in Ariba, it fails to integrate and does not create a corresponding document in SAP as the Ariba document number is likely to exist in SAP already.


Reproducing the Issue

For Example:
Customer has done a data refresh in their SAP QA (Quality Environment) System with the SAP PRD (Production) System and have replaced their QA data completely with production data.

Scenario:

  1. User creates a Purchase Requisition (PR) in the Ariba Test environment (example: PR3035).
  2. PR is approved and PurchaseOrderExportRequest (example: EP2345) is created and sent to SAP, but a new Purchase Order (PO) is not created in SAP.
    (Next two points are not necessarily done by Customers)
  3. User checks in SAP ECC for failure but finds an old PO (example: PO8000002487) for the corresponding PR in SAP already.
  4. User checks with their ERP/PI teams also and confirm that the Receiver Component for the Ariba create request is QA system only.

The reason why they see the PO in Test is that the PO was already created for PR3035 in production. As the data was copied, the same is seen in test. So no new PO is created for the PR.

If you are a customer reading this, please mention that the issue is seen only after SAP QA Data Refresh and include the new value. Also note, once a value has been updated in the realm then a lesser value cannot be applied. Please ensure the new value given is the correct value.


Cause

Normally, customers only do a data refresh for only Master Data. In this case both Master Data and Transaction Data were refreshed, which caused the issue.


Resolution

To address the issue, the sequencing of the affected Approvable document (PR/PO/RC, etc) must be updated. This is controlled by the Approvabletypes.csv. ApprovableIdInitialValue of the required Approvable document needs to be updated.

A Designated Support Contact (DSC) must log a Case as the Data Import/Export related to this file is not self service and cannot be accessed by Customer Administrators in the realm.


See Also

Please note, in Ariba system there is no option to directly transfer the transactional data from the Ariba Production system to Test system. The customer needs to create an improvement request if there is any requirement to have the transactional data also transfered.



Applies To

Core Procurement > Core Administration

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