Support Note KB0395170
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ActiveX Control troubleshooting guide for Windows 8.1 and Windows 10 for DFS related issue
Issue

The ActiveX control used for Desktop File Sync (DFS) and for exporting reports to an Excel spreadsheet needs to be manually installed, or requires troubleshooting on a user's machine because of malfunctioning.

Resolution

Even a user with administrative rights on the machine cannot browse the contents of the folder "C:\Windows\Downloaded Program Files", hence we need to remove files from and copy files to it using the command line prompt. That does not tamper with the permissions and ownership of this folder. To proceed with a remediation consisting in client cleanup and manual re-installation, follow these steps:

  1. Download the clientautomation.zip file attached to this page, and unzip its content to your C: drive.
  2. Open Start and type "cmd", right-click the icon called Command Prompt, and click Run as administrator.
  3. Type the following commands in sequence:

    • cd C:\Windows\Downloaded Program Files
    • regsvr32 /u clientautomation.dll

  4. Click OK on the confirmation window that appears, which says, "DLLUnregisterServer in C:\Windows\Downloaded Program Files\clientautomation.dll succeeded."

    • Move "C:\clientautomation\*" "C:\Windows\Downloaded Program Files"
    • regsvr32 clientautomation.dll

  5. Click OK on the confirmation window that appears, which says, "DLLRegisterServer in C:\Windows\Downloaded Program Files\clientautomation.dll succeeded."

After these steps, as a general other requirement for the ActiveX to work properly kindly check the ariba.com domain is part to the trusted sites list.

Kindly follow these steps,

  1. In Internet Explorer, click on the Tools icon in the top, right corner and, then, on Internet Options.
  2. Go to the tab Security, and select Trusted Sites among the four icons at the top, then, click Sites.
  3. Check if anything ending in "ariba.com" appears in the list.If not, add "https://*.ariba.com".

After all these steps, it's also a best practice to clear the browser's cache and cookies, which can also be done from Internet Options:

  1. Go to the General tab.
  2. In the section called Browsing history, click the Delete button.
  3. Among the available options in the next window, select only "Temporary Internet files and website files" and "Cookies and website data".
  4. Click OK. Then, close all browser windows.

Now you can try again to either export a report using an Excel template, or to enable DFS using one of the available methods.

Cause

The user does not have administrative rights and has to submit these instructions to his IT [Information Technology] department for central deployment. This IT department does not have access to the Ariba platform to trigger the automatic installation.

The extension file, clientautomation.dll, was corrupted and needed to be replaced.

Additional Information

At the moment the new UI [user interface] has a small issue in the DFS activation procedure. It occurs mostly when triggered by the notification received upon accessing a project in a realm, as opposed to clicking Preferences -> Change Desktop File Sync. A few symptoms and resolutions are:

In case your realm utilizes Enhanced Security for the delivery of the Active X control (the parameter Application.Base.EnableVeriSign2048CertificateAuthentication is set to Yes), you will need to download a different file for the installation.

The location of the CAB files for both versions are as follows:

To understand if the realm is configured in such way, please contact your DSC or Ariba Customer Support.

ActiveX Control troubleshooting guide for Windows 8.1 and Windows 10 for DFS related issue.zip77.15 KB

Applies To

Strategic Contracts
Strategic Sourcing
Supplier Information & Performance Management

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