FAQ KB0393839
Email
Why is my Purchase Order failing with Error: Order routing info not available?
Symptom

My Purchase Order (PO) is failing to send to the SAP Business Network due to the following error message:

Order Routing Info not available


Environment

SAP Ariba Buying & Invoicing


Cause

This error can be caused by the following reasons:

  1. The supplier location configuration is invalid. Some potential causes include the following:
    • The Preferred Ordering Method field is set to Email, but there is no Email address defined for the supplier location contact.
    • The Preferred Ordering Method field is set to Fax, but there is no fax number defined for the supplier location contact.
    • The Preferred Ordering Method field is set to URL, but there is no SAP Business Network ID (ANID) specified.
    • The Preferred Ordering Method field was changed after the order was created.

  2. The email tag within the correspondent tag is missing attribute name="routing".

  3. In SAP Business Network, quick enablement entitlement is activated. The Purchase Order CXML sent had a vendor ID with leading zeros. However, the vendor ID assigned in SAP Business Network did not include leading zeros. This mismatch caused SAP Business Network to attempt to create a new supplier but failed because it couldn't find routing information in the CXML, resulting in an error.

Resolution

Each resolution below corresponds to the possible causes listed above, respectively:

  1. Correct the supplier location configuration in one of the following ways:
    • Add an Email address to the supplier location configuration for a Preferred Ordering Method of Email.
    • Add a fax number to the supplier location configuration for a Preferred Ordering Method of Fax.
    • Change the Preferred Ordering Method to Electronic Ordering, and enter a valid ANID value in the SAP Business Network Id field.
    • If the Preferred Ordering Method field was changed after the order was created, you will need to create a new order. Ariba does not support changing a supplier's Preferred Ordering Method when there are in-flight documents for that supplier.

    After you correct the supplier configuration, the PO is sent successfully to SAP Business Network, unless it has permanently failed. If the PO history tab indicates permanent failure, the following article contains corrective actions you can take. KBA KB0393571:How do I resolve a purchase order that reaches Permanently Failed status?.

  2. Make sure attribute name="routing" exists in the email tag within the correspondent tag:
    <Email name="routing">supplier.email@provider.com</Email>

  3. The PO retrieves routing information from the vendor master data of the ERP system. If you are trying to create a new supplier, you can pass routing information. Otherwise, pass the vendor ID without leading zeros by following the steps in the SAP Integration Suite, Managed Gateway for Spend Management, and SAP Business Network Configuration Guide: SAP Help Portal: Uploading Supplier Records to the Activate Additional Outbound Messages for Specific Vendors Table in the .csv Format

See Also

For more details on Purchase Orders with a Permanently Failed status, please refer to KBA KB0393571:How do I resolve a purchase order that reaches Permanently Failed status?

For more information on uploading supplier records, refer to SAP Help Portal: Uploading Supplier Records to the Activate Additional Outbound Messages for Specific Vendors Table in the .csv Format in the SAP Integration Suite, Managed Gateway for Spend Management, and SAP Business Network Configuration Guide.



Applies To

Purchasing
SAP Business Network for Procurement & Supply Chain > Transaction Documents > Transaction (Purchase Orders, Ship Notices & Goods Receipts)
SAP Integration Suite Managed Gateway > Managed Gateway for Business Network

Terms of Use  |  Copyright  |  Security Disclosure  |  Privacy