Support Note 144071
Email
Error: "Authentication Error - Failed to validate the user" SSO login certificate expired
Issue

When trying to log in using single sign-on (SSO), I am getting the following error:

Authentication Error - Failed to validate the user. Please contact your administrator for further assistance.

The error log shows Failed to get Name id. Stack: ariba.util.saml.SAMLException: org.opensaml.xml.validation.ValidationException: Signature did not validate against the credential's key

Resolution

Contact SAP Ariba customer support to update the certificate in the your Site Profile with the certificate being sent from your side in the Security Assertion Markup Language (SAML) request.

Cause

The certificate sent in the SAML request is different than what is specified in your Site Profile.

Additional Information

If the error log includes Failed to get Name id. Stack: ariba.util.saml.SAMLException: condition is not valid instead of the above  Signature did not validate against the credential's key, see this article.

If you are instead getting the error Authentication Error - Authentication Failed, see Invalid SAML.


Applies To

SAP Ariba Buying and Invoicing
SAP Ariba Buying
SAP Ariba Contracts
SAP Ariba Services Procurement
SAP Ariba SIPM
SAP Ariba Sourcing

Terms of Use  |  Copyright  |  Security Disclosure  |  Privacy