支援注釋 124906
電子郵件
錯誤:無法連接至 PunchOut 目錄
問題

嘗試存取供應商的 PunchOut 目錄時,我收到下列錯誤訊息:

無法連接至 PunchOut 目錄。如果不斷出現該問題,請向系統管理員尋求幫助。

解決方案

請確認:

  1. 在採購商的 Ariba Procurement 解決方案內正確設定供應商的 ANID。
  2. 供應商在 PunchOutOrderMessage (POOM)中傳送商品代碼資料。 

傳送到 Ariba Network 的所有 PunchOutSetupResponse 文件必須包含 200 狀態代碼以及 StartPage 統一資源定位器 (URL)。當中任何差異將會構成無效 cXML 回應。

下方範例提供正確的 cXML 回應:

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

請與您的 IT 或開發團隊合作審核 PunchOut cXML 文件,確保您的應用程式滿足此功能正確運作的要求。

原因

此錯誤涉及建立與供應商 PunchOut 網站的初始連線。

出現此錯誤訊息的幾個常見原因如下:

其他資訊

請參閱《cXML 解決方案指南》,深入瞭解PunchOut 網站規劃


適用產品

SAP Ariba Catalog
SAP Business Network

使用條款  |  版權所有  |  安全披露  |  隱私權