支持注释 124906
电子邮件
错误:无法连接至 PunchOut 目录
问题

尝试访问供应商的 PunchOut 目录时,收到以下错误消息:

无法连接至 PunchOut 目录。如果问题仍然存在,请向您的系统管理员寻求帮助。

解决方法

确保:

  1. 在采购商 Ariba 采购解决方案中适当配置供应商的 ANID,并且
  2. 供应商将在 PunchOutOrderMessage (POOM) 中发送商品代码数据。 

所有发送至 Ariba Network 的 PunchOutSetupResponse 文档必须包含 200 状态代码和起始页统一资源定位器 (URL)。任何偏差均会导致无效的 cXML 响应。

以下示例提供了一个正确的 cXML 响应:

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

与 IT 或开发团队一起审阅 PunchOut cXML 文档,确保您的应用程序满足此功能正常运行的要求。

原因

错误涉及与供应商的 PunchOut 站点建立初始连接。

出现此错误消息的几个常见原因为:

其他信息

要了解有关 PunchOut 站点计划的详细信息,请参阅 cXML 解决方案指南


适用产品

SAP Ariba Catalog
SAP Business Network

使用条款  |  版权所有  |  安全披露  |  隐私