หมายเหตุของฝ่ายบริการลูกค้า 124906
อีเมล์
ข้อผิดพลาด: ไม่สามารถเชื่อมต่อแคตตาล็อก PunchOut
ปัญหา

ฉันได้รับข้อความแสดงข้อผิดพลาดต่อไปนี้เมื่อพยายามเข้าถึงแคตตาล็อก PunchOut ของคู่ค้า

ไม่สามารถเชื่อมต่อกับแคตตาล็อก PunchOut หากปัญหายังคงมีอยู่ กรุณาติดต่อผู้ดูแลระบบของคุณเพื่อขอความช่วยเหลือ

การแก้ไขปัญหา

ตรวจสอบให้แน่ใจว่า

  1. มีการกำหนดรูปแบบ ANID ของคู่ค้าอย่างเหมาะสมภายในโซลูชัน Ariba Procurement ของผู้ซื้อ และ
  2. คู่ค้าส่งข้อมูลรหัสกลุ่มสินค้าและบริการใน PunchOutOrderMessage (POOM) 

เอกสาร PunchOutSetupResponse ทั้งหมดที่ส่งไปยัง Ariba Network ต้องมีรหัสสถานะ 200 และ Uniform Resource Locater (URL) StartPage การเบี่ยงเบนใดๆ จากรายการนี้จะทำให้เกิดการตอบกลับ cXML ที่ไม่ถูกต้อง

ต่อไปนี้เป็นตัวอย่างที่มีการตอบกลับ cXML ถูกต้อง

<!DOCTYPE cXML SYSTEM "http://xml.cxml.org/schemas/cXML/1.2.014/cXML.dtd">
<cXML payloadID = "958074700772234234242" timestamp = "2005-06-14T12:59:09-07:00">
    <Response>
        <Status code = "200" text = "success"/>
        <PunchOutSetupResponse>
            <StartPage>
                <URL>https://punchout.company.com/Servlet/sessionid=7006</URL>
            </StartPage>
        </PunchOutSetupResponse>
    </Response>

ทำงานร่วมกับ IT หรือทีมพัฒนาของคุณในการตรวจทานเอกสารอธิบาย PunchOut cXML และตรวจสอบให้แน่ใจว่าแอพพลิเคชันของคุณสามารถตอบสนองความต้องการให้ฟีเจอร์นี้ทำงานได้อย่างถูกต้อง

สาเหตุ

ข้อผิดพลาดเกี่ยวข้องกับการสร้างการเชื่อมต่อเริ่มต้นกับไซต์ PunchOut ของคู่ค้า

สาเหตุทั่วไปบางประการสำหรับข้อความแสดงข้อผิดพลาดนี้มีดังนี้

ข้อมูลเพิ่มเติม

เรียนรู้เพิ่มเติมเกี่ยวกับการวางแผนไซต์ PunchOut ในคำแนะนำเกี่ยวกับโซลูชัน cXML


นำไปใช้กับ

SAP Ariba Catalog
SAP Business Network

เงื่อนไขการใช้งาน  |  ลิขสิทธิ์  |  การเปิดเผยข้อมูลเกี่ยวกับความปลอดภัย  |  ความเป็นส่วนตัว